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Comment démarrer  

 1 Comment démarrer ?  
1.1 Comment démarrer ToupSky ?   

1. Ouvrez l'écran de démarrage de Windows avec le bouton  du clavier, localisez 

ToupSky  et cliquez dessus pour démarrer l'application (Win 8/10) ;  

2. Cliquez sur le bouton Start (en bas à gauche de votre écran) et un menu Start 

s'affichera. Déplacez votre souris sur le menu et essayez de localiser ToupSky, 

cliquez pour le démarrer (Win XP/7) ;  

3. Double-cliquez sur l'icône du bureau “ ” (si installé) pour démarrer ToupSky ;  

1.2 Comment démarrer la caméra ?  

ToupSky détectera toutes les caméras installées sur votre ordinateur (ici, il s'agit de 

G3CMOS02300KPA, une caméra CMOS USB2.0 de 1,2 M pixels) et listera tous les noms 

de caméras sous le groupe Camera List dans la Camera Sidebar   

Cliquez sur la Camera Sidebar (si elle n'est pas activée) et sur la Camera List pour 

développer le groupe Camera List (si non développé).   

 

Cliquez sur le nom de la caméra (ici, il s'agit de G3CMOS02300KPA) pour démarrer la 

fenêtre vidéo et la caméra commencera à diffuser la vidéo. La fenêtre vidéo sera 

associée à un nom appelé “Video [G3CMOS02300KPA]” (c'est-à-dire, son titre sera 

“Video [G3CMOS02300KPA]”).  
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GUI de la fenêtre vidéo  

 2  Video window GUI  
2.1 GUI de la fenêtre vidéo  

  
A:ToupSky ;  

B: Menu ;  

C:Barre d'outils ToupSky ;  

D:Camera Sidebar ;  

E: Folders Sidebar ;  
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F: Undo/Redo Sidebar ;  

G: Histogram ;  

GUI de la fenêtre vidéo  

H:Statusbar ;  

I: Bouton Auto Hide ;   

J: Règle Horizontal ;  

K:Règle Vertical ;  

L:Camera Name;  

M:Frame Rate et Frames capturés ;  

N:Tailles Video actuelles ;  

O:Current Temperature;  

AA: Menu contextuel du bouton droit de la barre de titre ;  

AB: Menu contextuel du bouton droit de la Sidebar ;  

AC: Menu contextuel du bouton droit de la fenêtre Video ;  

AD: Menu contextuel du bouton droit de la barre d'outils  

AE: Menu contextuel du bouton droit de la Camera Sidebar ;  

AF: Menu contextuel du bouton droit de la Horizontal Ruler ou Vertical Ruler  

AG: Sous-menu Grids ;  

AH: Double-cliquez pour ouvrir la boîte de dialogue  Video Properties ;  

AI: Double-cliquez pour ouvrir la boîte de dialogue de configuration de l'affichage de la 
Temperature ;   

2.2 Comment fermer la fenêtre vidéo ?  

1 Double-cliquez sur le titre de la fenêtre vidéo avec onglets ou cliquez sur x sur  

pour fermer directement la fenêtre vidéo ;  

2. Choisissez la commande Windows>Close All pour fermer la fenêtre vidéo ;  

3. Cliquez avec le bouton droit de la souris sur le titre de la fenêtre vidéo pour invoquer 

le menu contextuel et choisissez  Close pour fermer la fenêtre vidéo ;  
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4. Appuyez sur Ctrl+W. 
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 3 GUI de la fenêtre d'image  
3.1 GUI de la fenêtre d'image  
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A:ToupSky ;  

B: Menu ;  

C:Barre d'outils ToupSky  

D:Camera Sidebar ;  

E: Folders Sidebar ;  

F: Undo/Redo Sidebar ;  

G: Sidebar ;  

H:Statusbar ;  

I: Bouton Auto Hide ;   

J: Règle Horizontal ;  

K:Règle Vertical ;  

L:Répertoire et nom du fichier ouvert ;  

M:Résolution du fichier image ;  

N:Ratio de Zoom de l'image, double-cliquez pour zoomer à 100 % ;  

AA: Menu contextuel du bouton droit de la barre de titre ;  

AB: Menu contextuel du bouton droit de la Sidebar ;  

AC: Menu contextuel du bouton droit de la fenêtre Video ;  

AD: Menu contextuel du bouton droit de la barre d'outils ;  

AE: Menu contextuel du bouton droit de la Horizontal Ruler ou Vertical Ruler 

; AF: Sous-menu Grids ;  

AG: Double-cliquez pour ouvrir la boîte de dialogue  Video Properties ;  

AH: Double-cliquez pour ouvrir la boîte de dialogue  

Scale Image ; AI: Menu contextuel du bouton droit 

du ratio de Zoom ;  

3.2 Comment fermer la fenêtre d'image ?  

1. Si vous avez modifié une image avant d'essayer de la fermer, double-cliquez 

sur le titre de la fenêtre d'image avec onglets ou cliquez sur x  sur  pour faire 

apparaître une boîte de dialogue ToupSky :  
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Cliquer sur Yes enregistrera les modifications sous son ancien nom et fermera 

rapidement la fenêtre, No fermera immédiatement le fichier sans modification ni 

avertissement, ou Cancel annulera la commande Close et laissera la fenêtre ouverte 

sans modification ;  

2. Si la fenêtre Image est détachée de la fenêtre vidéo et avec un numéro comme 

titre, double-cliquez sur le titre de la fenêtre d'image avec onglets ou cliquez sur x  sur 

 pour afficher une boîte de dialogue d'avertissement ToupSky :  

  
Cliquer sur Yes fera apparaître la boîte de dialogue Save As.  

   
Dans la boîte de dialogue Save As, choisissez   
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Save in : Sélectionnez le lecteur et le dossier dans lesquels vous souhaitez 

enregistrer votre fichier image dans la liste déroulante Save in et entrez le nom du 

fichier dans la zone de saisie File name ;  

Save : Cliquez sur Save pour enregistrer l'image capturée dans le répertoire et 

avec le nom de fichier spécifiés ;  

Cancel : Cliquez sur Cancel pour fermer la boîte de dialogue Save As et revenir à 
la fenêtre d'image.  

Cliquez sur No dans la boîte de dialogue ToupSky pour fermer immédiatement le fichier 

sans modification ni avertissement.  

Cliquez sur Cancel dans la boîte de dialogue ToupSky pour annuler la commande Close 

et revenir à la fenêtre d'image.  

3. Appuyez sur Ctrl+W ;  

Choisir la commande Window>Close All peut également fermer la fenêtre d'image avec 
onglets.  

Veuillez consulter la commande Window>Close All pour plus de détails.
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Barre d'outils UI  

 4 Barre d'outils UI  
Lorsque la caméra est démarrée ou l'image est ouverte (ou capturée), la plupart des 

icônes de la barre d'outils seront activées pour une opération rapide de la fenêtre vidéo 

ou image.  

  
1 : Open (Ctrl + O) ;  

2 : Save (Ctrl + S) ;  

3 : Quick Save (Quick Save);  

4. Auto Capture (F7)  

5. Batch Record(F10)  

6 : Zoom (Ctrl+ ou Ctrl-) 7 

: Video/Image Select;   

08:00 Track (activé uniquement lorsque la taille de la vidéo/image est supérieure à 

la taille de la fenêtre) ; 9 : Crosshairs pour l'alignement des étoiles ;  

10 : Circle pour l'alignement des étoiles ;  

11 :Circel with hole ;  

12 : ST4 Test ;  

13 : Previous Frame ;  

14 : Next Frame ;  

15 : Image Stitch ;  

16˖Preferences (Shift+P)  
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 5  Camera Sidebar   

La Camera Sidebar est utilisée pour le contrôle de 

la caméra, elle inclut plusieurs groupes (14). Le 

groupe peut être développé en a) cliquant sur le 

nom du groupe ou b) en cliquant sur les Double 

Down Arrow à l'extrémité droite du nom du 

groupe.  

  
5.1 Groupe Camera List  

Le Camera List listera toutes les caméras 
connectées à l'ordinateur qui prennent en charge 
l'application ToupSky. Cliquer sur   le nom de la 
caméra démarrera la fenêtre vidéo de la caméra.  

5.2 Groupe Capture & Resolution  

  

Snap : Capturez Snap des images en continu en 
cliquant dessus ;  

Record : Enregistrez Record le flux vidéo avec les 

formats pris en charge ;  

Resolution : Définissez la résolution vidéo ;  

Format : Le format vidéo, peut être RGB ou Raw ;  

Gain : Si et seulement si la luminosité est trop faible 

pour atteindre la limite supérieure du Exposure Time, 

faites glisser le curseur de Gain vers la droite jusqu'à ce 

que la luminosité vidéo soit normale ;  

Video Mode : L'application affichera en continu la vidéo 

dans la fenêtre Video ;  

Auto Exposure : Décochez la case Auto Exposure pour 

passer du mode Auto Exposure au mode Manual 

Exposure . Le curseur Exposure Target sera désactivé 

dans ce mode ;  

Lorsque le groupe Capture & Resolution est développé et 
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que le bouton Auto Exposure est coché ˈ, un rectangle 
vert   

  

marqué “Exposition” sera superposé sur la fenêtre 

vidéo. Cette région marquée est une région de référence 

pour juger si la luminosité moyenne de l'image atteint 

la valeur Exposure Target. Faire glisser le Exposure ROI 

vers la zone la plus sombre augmentera la luminosité 

vidéo et le faire glisser vers la zone la plus lumineuse 

réduira la luminosité vidéo ; Décochez la case Auto 

Exposure pour passer du mode Auto Exposure au mode 

Manual Exposure. Le  

curseur Exposure Target sera désactivé dans ce mode ;  
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Exposure Time : Faites glisser le curseur Exposure Time vers la gauche ou la droite 

jusqu'à ce que la luminosité de l'image soit normale ; Le temps d'exposition exact 

Exposure Time  peut également être saisi en cliquant sur la zone de saisie à 

l'extrémité droite du Exposure Time. Cela fera apparaître une boîte de dialogue 

appelée Exposure Time. Vous pouvez taper le nombre dans le champ pour définir la 

valeur exacte du Exposure Time .  

Trigger Source: L'utilisateur peut choisir le mode de déclenchement Software ou 
Hardware ;  

Exposure Time : Peut être défini en h (heure), m (minute), s (seconde), ms 

(milliseconde) et us (microseconde) ;  

Single : Prenez une seule image dans la fenêtre Video (le bouton Single deviendra le 

bouton Stop après avoir été cliqué) ;  

Loop : Prenez des images en continu dans la fenêtre Video jusqu'à ce que le bouton 

Stop soit cliqué (le bouton Loop deviendra le bouton Stop après avoir été cliqué) ;  

Sequence : Prenez un nombre spécifié d'images dans des fenêtres Image séparées 

(le bouton Sequence deviendra le bouton Stop après avoir été cliqué). Après la fin 

du processus ou le clic sur le bouton Stop, la capture de Sequence sera arrêtée et le 

bouton Stop redeviendra le bouton Sequence pour le prochain clic ;  

Options : Ce bouton invoquera une boîte de dialogue Sequence Options pour définir 
les Sequence Options telles que l'affichage de l'image capturée dans la fenêtre ou 
son enregistrement sur disque. L'utilisateur peut également choisir le Directory File 
prefix, le File type, etc. pour le fichier image à enregistrer.   
5.3 Groupe Balance des couleurs  

1. Cliquez sur la barre color balance  pour développer le groupe color balance et un 

rectangle rouge marqué avec white balance sera superposé sur la fenêtre vidéo ;  

2. Faites glisser le rectangle rouge vers une zone blanche pure ou grise et cliquez sur 

le bouton white balance  pour établir le white balance  de la vidéo pour le processus 

de streaming vidéo futur ;  
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5.5 Groupe Taux de 
rafraîchissement  

  

5.6 Groupe Couleur/Gris  

Faites glisser le curseur vers la droite (High) pour 

garantir que la caméra peut exécuter la vidéo à la 

plus haute Frame Rate  que le hub USB de 

l'ordinateur supporte. Si la vidéo ne s'affiche pas, 

faites glisser le curseur vers la gauche (Low) pour 

réduire le Frame Rate et cela permettra à la vidéo de 

se diffuser en mode basse vitesse.  

 

Si vous souhaitez prévisualiser la vidéo en Color, 

choisissez le bouton "Color", sinon, choisissez le bouton 

Gray.  

Si vous souhaitez prévisualiser la vidéo en Gray, cochez le  

1. Hue : Ajuste la Hue de la vidéo. Faites glisser le 

curseur vers la droite pour augmenter ou vers la 

gauche pour diminuer la Hue ;  

2. Saturation : Ajuste la Saturation de la vidéo. 

Faites glisser le curseur vers la droite pour augmenter 

ou vers la gauche pour diminuer la Saturation de la 

vidéo ;  

3. Brightness : Ajuste la Brightness de la vidéo. 

Faites glisser le curseur vers la droite pour augmenter 

ou vers la gauche pour diminuer la Brightness de la 

vidéo ;  

  

4. Contrast : Ajuste la Contrast de la vidéo. Faites glisser le curseur vers la 

droite pour augmenter ou vers la gauche pour diminuer la Contrast de la vidéo ;  

5. Gamma : Ajuste la Gamma de la vidéo. Faites glisser le curseur vers la droite 

pour augmenter ou vers la gauche pour diminuer la Gamma de la vidéo ;  

6. Defaults : Cliquez sur Defaults pour effacer tous les changements et les 

réinitialiser aux valeurs par défaut ;  

7. Tous vos réglages seront enregistrés pour le futur groupe Color Adjustment.  

  

3 . Si le 
réglage 

Balance des blancs  et   le  

réel  présentent encore une déviation, faites glisser 
les curseurs  

Roug
e 

,  Vert   ou  

Bleu  vers la gauche ou la droite pour corriger manuellement  le  

Balance des blancs .  

5.4   Groupe Ajustement des couleurs  
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bouton "Gray".  

5.7 Groupe Flip  
Si la vidéo à l'écran apparaît dans des directions 

différentes de celles vues sous la caméra, cochez la 

case "Horizontal" ou "Vertical" pour régler   

  
la direction de la vidéo dans la bonne position.  

5.8 Groupe Échantillonnage  

1. Bin : Le binning de pixels se réfère à la méthode 

de combinaison (moyenne) de pixels de blocs de 

pixels voisins de même couleur pour redimensionner 

la vidéo à   

  
une résolution inférieure ;  

2. Skip : Également appelé "Décimation", signifie 
qu'un certain nombre de pixels ne sont pas lus mais 
ignorés (horizontalement, verticalement ou dans les 
deux axes). Cela réduit la résolution de la vidéo 
résultante mais introduit des artefacts de sous-
échantillonnage.  

5.9 Groupe Profondeur de bits  

Basculer entre 8 bits et 12 bits. 8 bits est le format d'image de base  

de Windows. 12 bits aura une qualité d'image   plus 

élevée mais une vitesse de taux de trame modérée.  

5.10 Groupe ROI  

ROI, Région d'intérêt. Cette fonction peut définir 

le ROI sur la fenêtre vidéo. Lorsque le groupe ROI est 

développé, un rectangle en pointillé avec des 

"poignées"   

apparaîtra autour de la fenêtre vidéo permettant de modifier le ROI. Utilisez le 
bouton de la souris pour ajuster la taille du ROI. Si le ROI est correct, cliquez sur 
Apply pour définir la vidéo à la taille du ROI, Defaults reviendra à l'original.  
5.11 Groupe Histogramme  

1. Un Histogram illustre comment les pixels dans une image sont distribués en traçant 

le nombre de pixels à chaque niveau d'intensité de couleur. L'Histogram montre les 
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détails dans les ombres (montrés dans la partie gauche de l'histogramme), les tons 

moyens (montrés au centre),  

et les hautes lumières (montrées dans la partie droite). Un Histogram peut vous 

aider à déterminer si une image a suffisamment de 

détails pour effectuer une bonne correction ;  

2. Ce groupe montre l'Histogram de la vidéo active 

actuelle. Deux marqueurs de ligne verticale montrent 

les limites supérieure et inférieure des niveaux 

d'intensité. Ces marqueurs peuvent être déplacés 

avec la souris. Si vous regardez une image couleur, 

l'Histogram reflétera les valeurs RGB (histogramme 

des canaux rouge, vert et bleu en même temps) R 

(rouge), G (vert), et B (bleu) avec des lignes de la même couleur ;  

3. Vous pouvez également entrer directement les valeurs souhaitées dans les 

cases Left ou Right sous le graphique de l'Histogram pour les limites de l'Left et de 

l'Right Histogram ;  

4. Cliquez sur le bouton ĀRefreshā pour mettre à jour l'affichage de l'Histogram 

si l'échantillon en observation est déplacé ou modifié ;  

5. Cliquer sur le bouton Defaults remettra les limites de l'Left et de l'Right 

Histogram à leurs valeurs d'origine ;  

6. Cliquez sur le bouton Auto  pour localiser automatiquement les deux limites 
afin d'obtenir la meilleure qualité vidéo.  

 
5.13 Groupe de refroidissement  

Le Cooling group est disponible uniquement pour ceux qui ont du matériel de 

refroidissement TE à l'intérieur de la caméra.  

5.12   Correction du champ sombre  

  

Pou
r  

activer  le  Correction du champ sombre ,  il faut  

d'abord capturer l'image du champ sombre. Après avoir   

capturé les images, le  activer   sera activé.  

Cochez cette case pour activer le  correction du champ sombre .  

Décochez cela désactivera la  Correction du champ 
sombre 

.  



Barre latérale de la caméra  

24  

TEC On : Le refroidissement sera activé lorsque ce bouton est choisi ;   

TEC Target : La valeur de température finale souhaitée ;  

TEC Off : Le refroidissement sera désactivé lorsque ce bouton est choisi ;  

 

Le Parameters group est utilisé pour enregistrer les 

paramètres de contrôle de la caméra définis pour une 

application ultérieure.  

Cliquez sur Save pour enregistrer les paramètres 

de contrôle actuels de la caméra avec un nouveau 

fichier de paramètres, puis les boutons Load et Overwrite seront activés.   

Cliquez sur Load pour charger les paramètres de contrôle de la caméra enregistrés 
;  

Cliquez sur Overwrite pour écraser les paramètres de contrôle de la caméra actuels 

avec le fichier de paramètres de contrôle de la caméra actuellement chargé ;  

Cliquez sur Management pour ouvrir une boîte de dialogue Management  dans 
laquelle il est possible de gérer tous les fichiers de  Parameter enregistrés.  

  

Venti
lateu

On :  Ouvrir le ventilateur accélérera la  

vitesse 
de 

  

Ventilate
ur Off 

:  Arrêter le ventilateur réduira le  bruit sonore du 
ventilateur  mais diminuera la vitesse de 

refroidissement 
.  

5.14   Groupe de paramètres  
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 6  Fichier  

6.1 Ouvrir une image•••      Ctrl+O  

Choisissez la commande File>Open Image•••  pour ouvrir un fichier image existant. La 

commande Open Image••• peut également être utilisée pour prévisualiser une image 

en petite taille, ou pour afficher ses statistiques et informations sans ouvrir réellement 

l'image elle-même. Ces capacités peuvent être utilisées pour localiser rapidement une 

image particulière.  

ToupSky prend en charge et peut ouvrir de nombreux formats d'image. Ceux-ci sont 

identifiés dans la boîte de liste Files of type.  

  

Plusieurs images peuvent être ouvertes simultanément dans ToupSky en utilisant a) la 

méthode Ctrl + left mouse button  et b) la méthode Shift + left mouse button method 

pour sélectionner les fichiers à ouvrir. Dans ce mode, la fenêtre Preview sera 

désactivée.  

Lorsqu'une image est ouverte, ToupSky la place dans une nouvelle fenêtre d'image. 

Elle devient alors la fenêtre active.  
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Remarque : ToupSky maintient, dans les sous-menus File>Recent Files, une liste des 

4 derniers fichiers ouverts (peut être de 1 à 8). N'importe lequel de ces fichiers peut 

être accessible en cliquant simplement sur le nom du fichier.  

Si aucun fichier n'est répertorié dans le sous-menu File>Recent Files, la commande 

Open Image••• doit être utilisée pour ouvrir le fichier.  

De plus, la commande View>Browse(Ctrl+B) peut être utilisée pour visualiser des 

images en format Icon dans n'importe quel répertoire sélectionné. Des informations 

succinctes sont données dans le menu View>Browse .  

File name: Dans cette boîte de liste, sélectionnez le nom du fichier que vous souhaitez 

ouvrir. Saisissez soit le nom du fichier (avec son chemin complet, s'il n'est pas dans le 

dossier courant), soit sélectionnez Files of type  pour obtenir une liste de File names. 

Double-cliquer sur un nom de fichier dans la grande boîte combinée (où les noms de 

dossiers et de fichiers sont listés) l'ouvrira automatiquement.  

Remarque : Si vous tapez simplement dans le champ File name, assurez-vous que le 

champ Files of type identifie correctement le format du fichier à ouvrir. Sinon, des 

messages d'erreur s'afficheront lorsque ToupSky essaiera d'ouvrir le fichier.  

Files of type: Dans cette boîte de liste, sélectionnez le format d'image du fichier à 

ouvrir. Si vous sélectionnez All supported formats, ToupSky utilise l'extension du 

fichier pour identifier son format. ToupSky prend en charge les formats de fichiers 

suivants :  

Bitmap Windows(*.bmp,*.dib,*.rle)  

JPEG(*.jpg,*.jpeg,*.jpe,*.jif,*.jfif)   

Portable Network Graphics(*.png)   

Tag Image File Format(*.tif, *.tiff)   

Compuserve GIF (*.gif)   

PCX˄*.pcx˅  

Targa(*.tga)   

PhotoShop(*.psd)   

ICON(*.ico)   

Enhanced Window Metafile(*.emf)   

Window Metafile(*.wmf)   
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JBIG(*.jbg)   

Wireless Bitmap(*.wbmp)   

JPEG 2000 Standard(*.jp2)  

JPEG 2000 Codestream(*.j2k)  

Digital Negative (*.dng)  

Ser (*.ser)  

Fits(*.fit;*.fits)  

Si le fichier image n'utilise pas des extensions de format standard, il faut taper le fichier 

dans le champ File name, puis sélectionner son format dans la boîte de liste Files of 

type .  

Sinon, ToupSky sélectionnera un format en fonction de l'extension du nom de fichier.  

Preview : Cliquez sur ce bouton pour prévisualiser l'image en petite taille. En mode 

aperçu, des statistiques et des informations sur l'image (c'est-à-dire  Width, Height et 

localisation de l'image) seront affichées. Par défaut, il n'y a pas Preview.  

Current File : Localisation du Current File sur votre ordinateur ;  

Width : Largeur de Current File ;  

Height : Hauteur de Current File ;  

6.2 Ouvrir une vidéo•••      

Le menu File>Open Video•••  sera activé uniquement lorsqu'aucun fichier vidéo n'est 

ouvert dans le cadre ToupSky ou qu'aucune caméra n'est ouverte.  

1. Choisissez la commande File>Open Video••• pour ouvrir un fichier vidéo existant ;  
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2. Sélectionnez le nom du fichier que vous souhaitez ouvrir. Si le fichier n'apparaît pas, 

sélectionnez l'option pour afficher tous les fichiers dans la Files of Type boîte de 

dialogue. Le type de fichier vidéo peut être l'un des suivants.  

  

3. Cliquez sur Open pour ouvrir un fichier vidéo, cela créera une fenêtre vidéo et 

commencera à lancer le flux vidéo. La fenêtre vidéo sera associée à un nom appelé 

« Video [XXX.XXX] » (c'est-à-dire que sa barre de titre affichera « Video [XXX.XXX] 

», ici, XXX.XXX est le nom du fichier vidéo).  

4. Cliquez sur Cancel pour revenir à l'application.  

Remarque : Une seule vidéo peut être ouverte à la fois. ToupSky considère la caméra 

comme un fichier vidéo spécial, si la caméra est ouverte, ce menu sera désactivé et le 

fichier vidéo ne pourra plus être ouvert.  

6.3 Enregistrer       Ctrl+S  

Choisissez la commande File>Save pour stocker immédiatement l'image de la fenêtre 

actuelle dans son fichier (le nom du fichier est indiqué sur la barre de titre de la fenêtre) 

tout en laissant l'image active dans sa fenêtre.  

Si l'image est sans titre ou titrée avec un chiffre, ToupSky lancera automatiquement la 

boîte de dialogue File>Save As•••. Le « Save as type » par défaut sera « Bitmap 

Windows  

(*.bmp,*.dib,*.rle) ».  

La commande File>Save peut être utilisée pour enregistrer les modifications les plus 

récentes sur le disque. Elle est souvent effectuée par mesure de précaution lors de 

processus longs ou complexes pour réduire la quantité de retraitement qui pourrait être 

nécessaire en cas de défaillance du système ou d'erreur opérationnelle. Lorsque une 

image est fermée et que l'option de ne pas enregistrer ses modifications est choisie, 

ToupSky annule toutes les modifications apportées depuis la dernière opération 

File>Save.  
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Remarque : a). La commande File>Save enregistre toujours le contenu de l'ensemble 

de la fenêtre, même s'il y a une AOI (Area of Interest) définie dessus ; b). La commande 

File>Save sera désactivée si le fichier n'est pas modifié ou si les modifications ont été 

enregistrées.  

6.4 Enregistrer sous•••  

Choisissez la commande File>Save As••• pour stocker le contenu de la fenêtre actuelle 

dans un format de fichier spécifié. À la fin d'une opération File>Save As•••, la fenêtre 

d'image sera associée au nouveau fichier et au nouveau format (c'est-à-dire que sa 

barre de titre affichera le nouveau nom de fichier).  

Les formats d'enregistrement de fichiers pris en charge par ToupSky sont :  

Bitmap Windows(*.bmp,*.dib,*.rle)  

JPEG(*.jpg,*.jpeg,*.jpe,*.jif,*.jfif)  

Portable Network Graphics(*.png)  

Tag Image File Format(*.tif, *.tiff)  

Compuserve GIF (*.gif)  

PCX (*.pcx)  

Targa(*.tga)  

JBIG(*.jbg)  

JPEG 2000 Standard(*.jp2)  

JPEG 2000 Codestream(*.j2k)  

Fits (*.fit)  
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Save in : Trouvez le dossier où le fichier doit être enregistré. Un nouveau dossier peut 

être créé en utilisant le bouton New Folders ;  

File name : Le nom du fichier à enregistrer. Pour spécifier l'emplacement du fichier, 

saisissez son chemin complet (disque et dossier) ou spécifiez son emplacement en 

utilisant la boîte de liste Save in ;  

Save as type : Dans cette boîte de liste, sélectionnez le format dans lequel l'image doit 

être enregistrée. Save As••• est également utilisé pour convertir une seule image d'un 

format à un autre. Par exemple, si un fichier TIFF doit être converti au format PCX, 

ouvrez d'abord l'image TIFF, puis choisissez la commande Save As••• avec le format 

PCX pour l'enregistrer dans un nouveau fichier.  

Le « Save as type » par défaut sera « Window Bitmap (*.bmp,*.dib,*.rle) ». La 

commande Save As a plusieurs utilisations importantes au-delà du simple stockage 

d'une image sous un nouveau nom de fichier. Cliquez sur Option pour sélectionner les 

différents paramètres pour encoder le fichier.  

6.4.1 Option pour JPEG  

Pour JPEG (*.jpg,*.jpeg,*.jpe,*.jif,*.jfif), Option a les éléments suivants :  
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Image quality: Si une image est enregistrée au format JPEG (*.jpg), il est possible 

d'ajuster la qualité de l'image dans la zone de saisie. Les valeurs varient de 0 à 100. 

Valeur par défaut : 75 ;  

Progressive: La valeur par défaut est décochée ;  

Optimize Huffman codes: La valeur par défaut est décochée ;  

Smoothing: Les valeurs varient entre 0 et 100. Valeur par défaut : 0 ;  

Save these setting as defaults: Lors de l'enregistrement d'un fichier, les paramètres 

actuels seront enregistrés comme valeurs par défaut pour la prochaine opération 

d'enregistrement de fichier.  

6.4.2 Option pour PNG  

Pour Portable Network Graphics (*.png), Option a les éléments suivants :  

Interlaced: La valeur par défaut est décochée ;  

Save these setting as defaults: Lors de l'enregistrement d'un fichier, les paramètres 

actuels seront enregistrés comme valeurs par défaut pour la prochaine opération 

d'enregistrement de fichier.  
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6.4.3 Option pour TIF  

Pour Tag Image File Format (*.tif, *.tiff), Option a les éléments suivants :   

  

Appended pages: Détermine si l'image actuelle sera enregistrée dans un style de pages 

multiples ou non ;  

Compressions: Spécifie une méthode pour compresser les données de l'image 

composite. Pour enregistrer un fichier 32̻bit TIFF , il est possible de spécifier que le 

fichier soit enregistré avec une compression de prédicteur, mais il n'y a pas d'option 

pour utiliser la compression JPEG. La compression de prédicteur offre une meilleure 

compression en réorganisant les valeurs en virgule flottante, et fonctionne avec les 

compressions LZW et ZIP ;  

Image quality: Si vous choisissez Compressions as "JPEG", la Image quality peut être 

ajustée par la barre de défilement. Les valeurs varient entre 0 et 100. Valeur par défaut 

: 75 ;  
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Save these setting as defaults: Lors de l'enregistrement d'un fichier, les paramètres 

actuels seront enregistrés comme valeurs par défaut pour la prochaine opération 

d'enregistrement de fichier.  

6.4.4 Option pour les autres formats  

Pour Compuserve GIF (*.gif); PCX(*.pcx); Targa(*.tga); JBIG(*.jbg); FITS(*.fit) il n'y 

a pas d' Option.  

Remarque : a) Des informations détaillées sur les terminologies académiques ci-dessus 

peuvent être trouvées dans des livres sur le traitement des images et la compression 

des images ou sur Internet ; b) Le répertoire de sauvegarde des fichiers peut être 

restauré pour une utilisation future. Pour conserver le répertoire inchangé au 

redémarrage de ToupSky, choisissez la commande Options>Preferences•••, cliquez sur 

la page Misc et cochez Restore the current directory when startup sous l'élément 

Privacy.  

  
6.5 Enregistrement par lot•••  

Le menu File>Batch Save••• sera activé lorsque a) une image est ouverte ; b) une 

image est capturée depuis la caméra ; c) une fenêtre d'image est créée en choisissant 

la commande File>Paste as New File ; d) une fenêtre d'image est copiée depuis la 

Undo/Redo Sidebar avec le bouton de copie comme indiqué ci-dessous :  
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6.5.1 Enregistrement par lot pour une fenêtre d'image de style a)  

Si l'image est modifiée, choisir la commande File>Batch Save••• enregistrera le fichier 

avec son nom de fichier ouvert et son extension ;  

6.5.2 Enregistrement par lot pour une fenêtre d'image de style b), c) ou 
d)  

Si la fenêtre d'image a été créée avec le style b), c) ou d), choisir la commande 

File>Save As••• pour réaliser la tâche de sauvegarde du fichier sera chronophage. La 

commande Batch Save••• exécute la commande File>Save As••• avec le nom 

automatiquement spécifié selon le paradigme spécifié dans la boîte de dialogue Batch 

Save   

Pour démarrer la commande File>Batch Save••• pour une fenêtre d'image de style b), 
vous devez   

1. Démarrez la caméra ;  

2. Capturez au moins une image en premier ;  

3. Choisir la commande File>Batch Save••• fera apparaître une boîte de dialogue Batch 
Save :  

  
Directory : Entrez le nom du lecteur et du répertoire où vos images capturées seront 

sauvegardées. Vous pouvez soit taper les informations du chemin, soit utiliser le bouton 

Browse pour le localiser depuis une boîte de dialogue Browse Folder standard.  

Name Format : Les year, month, date, hour, minute et second ou nnnn(sequence) sont 

utilisés comme partie du nom de fichier. Si plusieurs fichiers sont sauvegardés en une 

seconde, un suffixe (xx) est ajouté à la fin de Name Format pour éviter les conflits de 

nom. Pour le « nnnn(sequence) » de « Name Format », aucun suffixe n'est nécessaire.  
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File Prefix : Entrez un préfixe de nom de fichier pour Batch Save lors de la génération 

des noms de fichiers pour une série d'images. Ce préfixe sera combiné avec Name 

Format pour former un paradigme de nommage final du fichier.  

File Type : Dans cette combobox, sélectionnez le format dans lequel vous souhaitez 

enregistrer l'image (peut être BMP, JPG, PNG, TIF, FIT). Les paramètres pour encoder 

le fichier (Pour le BMP or FIT format, il n'y a pas d'options). Voir 

Options>Preferences•••>File  page, choisissez la ligne de format de fichier et cliquez 

sur le bouton Config••• pour plus de détails. Ou vérifiez les Options>Preference>File 

dans la section 14.1.4  

Sample : Le nom de fichier final est affiché à droite de l'étiquette Sample pour 
référence.  

4. Si les réglages dans la boîte de dialogue Batch Save sont terminés, cliquez sur le 

bouton OK pour commencer le processus de sauvegarde par lot ou Cancel pour annuler 

la commande Batch Save et revenir à l'application.  

Pour les fenêtres d'image de style c) ou d), seules les étapes 3 et 4 sont nécessaires.  

Rermarque : a) Dans le processus de la commande File>Batch Save•••, le titre de 

l'onglet de l'image ou de la fenêtre de l'image sera modifié avec le paradigme de nom 

de fichier dans la boîte de dialogue Batch Save.  

b) La commande File>Batch Save••• n'effectuera aucune opération de sauvegarde si 
le fichier n'est pas modifié ou inchangé.  

6.6 Coller comme nouveau fichier  

Le menu File>Paste as New File sera activé uniquement lorsqu'il y a des données 

d'image valides dans le presse-papiers (voir le menu Edit>Copy). S'il n'y a pas de 

données d'image dans le presse-papiers, le menu File>Paste as New File sera désactivé.  

Choisissez la commande File>Paste as New File pour placer le contenu de l'image du 

presse-papiers dans une nouvelle fenêtre d'image, qui devient la fenêtre active.  

Le nouveau type d'image sera le même que celui de l'image originale. ToupSky 

acceptera les données d'image d'autres applications via le presse-papiers tant qu'elles 

sont au format Windows Bitmap (DIB).  
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Remarque : ToupSky attribuera un chiffre à la barre de titre de la fenêtre d'image créée 

par la commande Paste as New File.  

6.7 Fichiers récents  

ToupSky conserve 4 (par défaut) fichiers de documents les plus récemment ouverts 

sous le menu Recent Files. Choisir l'un de ces sous-menus rouvrira immédiatement ce 

fichier.  

Remarque : a) The maximum number of Recent Files peut être modifié en choisissant 

la commande Options>Preferences••• et en cliquant sur la page Misc comme indiqué 

ci-dessous :  

  
Ici, en cliquant sur la boîte d'édition 4 (par défaut), vous pourrez entrer le nombre de 

sous-menus Recent Files que vous souhaitez. Les valeurs varient de 0 à 8, la valeur 

par défaut est 4 ; b) Vous pouvez également cocher Clear the Recent Files when exit 

the application pour effacer les Recent Files après avoir quitté l'application ToupSky.  

6.8 Quitter  

Choisir la commande File>Exit fermera la fenêtre vidéo, toutes les fenêtres d'image et 

la fenêtre Browse. Après la fermeture de toutes les fenêtres, ToupSky se terminera.  

Remarque : Si une image a été modifiée avant de tenter de Exit, ToupSky émettra un 

avertissement pour demander si l'utilisateur souhaite enregistrer l'image ou non 

d'abord.  
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Si plusieurs images ont été modifiées avant de tenter de Exit, ToupSky émettra une 

boîte de dialogue Save Files pour diriger l'utilisateur à enregistrer les modifications de 

différentes manières.  

  
Voir Window>Close All pour plus de détails.
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 7 Modifier  

7.1 Couper      Ctrl+X  

Le menu Edit>Cut sera activé uniquement lorsque les fichiers image dans la fenêtre 

Browse sont sélectionnés.  

7.1.1 Couper pour les fichiers sélectionnés dans la fenêtre Browse  

Lorsque la fenêtre Browse est active et que les fichiers image dans la fenêtre Browse 

sont sélectionnés, la commande Edit>Cut sera activée. Choisir la commande Edit>Cut 

la copiera dans le presse-papiers. Après que le(s) fichier(s) soit(ent) collé(s), le(s) 

fichier(s) sera(seront) supprimé(s).   

Remarque : La commande Edit>Cut ne prend pas en charge l'opération Cut d'image 
dans ToupSky.  

7.2 Copier       Ctrl+C  

7.2.1 Copier la zone sélectionnée dans le presse-papiers  

Dans la fenêtre vidéo ou la fenêtre d'image, choisissez la commande Edit>Copy pour 

Copy la zone sélectionnée d'une vidéo ou d'une image dans le presse-papiers.  

Remarque : Lorsqu'une ROI d'image est sélectionnée, le menu Edit>Copy sera activé.  

7.2.2 Copier les fichiers sélectionnés dans la fenêtre Browse dans le 
presse-papiers  

Lorsque la fenêtre Browse est active et que les fichiers image dans la fenêtre Browse 

sont sélectionnés, la commande Edit>copy sera activée. Choisir la commande 

Edit>Copy les copiera alors dans le presse-papiers.  

Remarque : Les fichiers copiés sur le presse-papiers peuvent être collés dans la fenêtre 

Browse en choisissant la commande Edit>Paste ou le raccourci Browse>Paste.  

7.3 Coller       Ctrl+V  

S'il y a des fichiers image sur le presse-papiers et que la fenêtre active actuelle est la 

fenêtre Browse, le menu Edit>Paste sera activé.  
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7.3.1 Coller les fichiers du presse-papiers dans la fenêtre Browse  

Lorsque la fenêtre Browse est active et que les fichiers image dans la fenêtre Browse 

sont sélectionnés, la commande Edit>Paste sera activée. Choisir la commande 

Edit>Paste collera les fichiers du presse-papiers dans la fenêtre Browse.  

Remarque : La commande Edit>Paste ne prend pas en charge l'opération Paste de la 
zone d'image.  

7.4 Raccourci Coller  

Cette commande est uniquement pour la fenêtre Browse. Ce menu sera activé lorsque 

des fichiers dans la fenêtre Browse sont sélectionnés et que la commande Edit>Copy 

est exécutée pour copier le raccourci du fichier dans le presse-papiers. Choisir cette 

commande créera les fichiers Shortcut (au format *.lnk) du presse-papiers dans le 

répertoire actuel de la fenêtre Browse.  

Si le fichier *.lnk à coller existe déjà dans la fenêtre Browse, ToupSky affichera une 

boîte de dialogue de confirmation.  

  
Vous pouvez cliquer sur Yes, No ou Cancel pour écraser, abandonner ou annuler la 
commande.  

7.5 Supprimer      Supprimer  

Le menu Browse>Delete File sera activé si le(s) fichier(s) est (sont) mis en surbrillance 

dans la fenêtre Browse. Cette commande est uniquement pour la fenêtre Browse.  

Vous pouvez Delete ou retirer un ou plusieurs fichiers de la fenêtre Browse. Les étapes 

sont les suivantes :  

7.5.1 Pour supprimer un fichier dans la fenêtre Browse  

1. Sélectionnez un ou plusieurs fichiers en a) Cliquant sur les icônes de fichiers 

affichées, un seul fichier sera mis en surbrillance ; b) Cliquant sur les fichiers un par un 

avec Ctrl + bouton gauche de la souris, tous les fichiers cliqués seront mis en 
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surbrillance ; c) Cliquant sur les icônes de fichiers affichées, le premier fichier cliqué 

sera mis en surbrillance, en cliquant sur le fichier de fin avec Shift + bouton gauche de 

la souris, tous les fichiers entre le premier et le dernier seront mis en surbrillance. d) 

En faisant glisser la souris pour tracer un rectangle en pointillé autour des fichiers que 

vous souhaitez supprimer, tous les fichiers dans le rectangle seront mis en surbrillance 

; e) Ctrl+A pour sélectionner tous les fichiers dans la fenêtre Browse.  

2. a) Appuyez sur la touche Delete pour supprimer les fichiers sélectionnés ; b) 

Cliquez avec le bouton droit de la souris pour faire apparaître un menu contextuel, 

choisissez la commande Delete pour supprimer les fichiers mis en surbrillance.  

Une boîte de dialogue Confirm File Delete apparaîtra.  

Dans la boîte de dialogue Confirm File Delete, cliquez sur Yes pour déplacer les fichiers 

vers la corbeille du bureau, ou sur No pour annuler l'opération Delete.  

7.6 Sélection d'image     

La commande Edit>Image Select peut être utilisée pour marquer ROI et Copier la ROI 

sélectionnée dans le presse-papiers. Cette commande est uniquement utilisée pour 

sélectionner l'image ROI.  

Choisir la commande Edit>Image Select cochera ce menu (ou cliquer sur  dans la 

barre d'outils maintiendra  enfoncé) et le curseur se transformera en «  ». Les 

étapes de sélection de la ROI sont décrites ci-dessous :  

1. Après avoir choisi la commande Edit>Image Select, faites glisser le curseur de 

la souris sur l'image en maintenant le bouton gauche enfoncé jusqu'à ce que la zone 

soit sélectionnée ;  

2. Relâchez le bouton gauche et la zone sera marquée. Des poignées apparaîtront 

sur le bord de la zone permettant de modifier la sélection après qu'elle soit marquée.  
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7.7 Sélectionner tout    Ctrl+A  

7.7.1 Sélectionner tout sur la fenêtre vidéo/image  

Lorsque la fenêtre vidéo/image est active, choisir la commande Select All sélectionnera 

tous les pixels de la video/image sur la toile (raccourci :  Ctrl+A).  

7.7.2 Sélectionner tous les fichiers dans la fenêtre Browse  

Lorsque la fenêtre Browse est active, choisir la commande Edit>Select All sélectionnera 

tous les fichiers dans la fenêtre Browse sous le répertoire spécifié dans la Folders 

Sidebar.  

7.8 Désélectionner tout  Ctrl+D  

Désélectionner a) toute zone sélectionnée (ROI) sur l'image ; b) le fichier listé dans la 

fenêtre Browse.  

7.8.1 Désélectionner tout pour la ROI vidéo/image  

Lorsque une zone vidéo ou image est sélectionnée, le menu Select None sera activé. 

Choisir la commande Edit>Select None supprimera le rectangle pointillé représentant la 

zone sélectionnée (ROI).  

7.8.2 Désélectionner tout pour la fenêtre Browse  

Lorsque la fenêtre Browse est active et que les fichiers image dans la fenêtre Browse 

sont sélectionnés, la commande Edit>Select None sera activée. Choisir la commande 

Edit>Select None désélectionnera tous les fichiers sélectionnés dans la fenêtre Browse.  
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 8  Vue  

8.1 Parcourir      Ctrl+B  

8.1.1 Ouvrir la fenêtre Browse  

1. Choisissez le menu View>Browse ou cliquez sur le bouton Browse de la barre 

d'outils  pour ouvrir ou activer les images de navigation sous le répertoire spécifié 

dans la Folders Sidebar ;  

2. Cliquez sur la Folders Sidebar pour l'activer et double-cliquez sur le répertoire 

listé dans la Folders Sidebar pour créer la fenêtre Browse.  

Après avoir créé la fenêtre Browse, ToupSky affichera une fenêtre Browse qui ressemble 

à l'explorateur Windows. La fenêtre enfant sur la partie gauche de la fenêtre Browse 

appelée Folders Sidebar est utilisée pour localiser le répertoire sur le disque dur. Les 

images dans le répertoire actuel sont affichées en mode Large Icons ou Small Icons sur 

le côté droit de la fenêtre Browse.  

L'ordre des fichiers image peut être défini en Ascending ou Descending selon le Sort par 

Name, Type, Size, Width ou Height etc.  

8.1.2 Menu contextuel du bouton droit de la fenêtre Browse  

Cliquer avec le bouton droit sur l' Icon listé dans la fenêtre Browse fera apparaître un 

menu contextuel comme indiqué ci-dessous :  

  
Ces fonctions de menu contextuel sont décrites dans  

Edit>Cut  Browse>Sort>Sort by Names  Process>Stitch  
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Edit>Copy  Browse>Sort>Sort by Type  

Edit>Paste  Browse>Sort>Sort by Size   

Edit>Paste  

Shortcut  

Edit>Delete  

Browse>Sort>Sort by Width  

Browse>Sort>Sort by Height  

Browse>Sort>Ascending  

Browse>Sort>Descending  

Browse>Icon>Large Icons  

Browse>Icon>Small Icons  

Browse>Refresh  

Browse>Properties  
menus. Veuillez les consulter pour plus de détails.  

Remarque : La Folders Sidebar et le Browse peuvent être utilisés pour effectuer des 

tâches telles que la création de nouveaux dossiers, le renommage, le déplacement et la 

suppression de fichiers. Des informations individuelles sur les fichiers et l'importation 

de données depuis des appareils photo numériques peuvent également être affichées. 

Double-cliquer avec le bouton gauche sur l'icône ouvrira l'image comme une image 

active en pleine taille. Voir Image window GUI dans la section 3 pour plus de détails.  

8.2 Barre latérale  

Il y a 3 Sidebars dans la fenêtre cadre de ToupSky sous forme d'onglets. Elles sont 

Camera Sidebar, Folders Sidebar et Undo/Redo Sidebar.  

8.2.1 Vue d'ensemble de la barre latérale  

  
AA: Camera Sidebar ;  
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AB: Camera Sidebar groupes pour le contrôle de la caméra.  

BA : Folders Sidebar ; 

BB : Back au dossier précédent ;  

BC : Forward au dossier suivant ;  

BD : Browsing les images sous le répertoire de fichiers de l'application ;  

BE : Ouvrir la fenêtre Browse si elle n'est pas ouverte (Double-cliquer sur le répertoire 

sélectionné effectuera les mêmes fonctions.);  

BF : Folders pour localiser le répertoire de fichiers de la fenêtre Browse.  

CA : Undo/Redo Sidebar ;  

CB : Avancer vers l'étape précédente ;  

CC : Reculer vers l'étape suivante ;  

CD : Operation Copy : Copier l'opération surlignée dans la Undo/Redo Sidebar dans une 

nouvelle fenêtre d'image ; L'utilisateur peut également faire glisser l'opération 

sélectionnée dans la Undo/Redo Sidebar vers la zone de la fenêtre pour créer une 

nouvelle fenêtre d'image ;  

CE : Remove les opérations surlignées de la liste Undo/Redo (Ce bouton sera activé 

uniquement lorsque l'opération est sélectionnée, l'image ouverte (la première 

opération) ne peut pas être supprimée ;  

CF : Indiquant l' Current opération affichée dans la fenêtre d'image 

; CG : Operation Index ; CH : Operation name.  

8.2.2 Sidebar>Camera  

La Camera Sidebar est principalement utilisée pour le contrôle de la caméra, elle 

comprend de nombreux groupes. Chaque groupe peut être développé en cliquant sur le 

nom du groupe ou sur le bouton flèche à droite du nom du groupe.  

Cochez le menu Sidebar>Camera pour l'activer/l'afficher dans le groupe de la barre 
latérale.  

Veuillez consulter Camera Sidebar dans la section 5 pour plus de détails.  

8.2.3 Sidebar>Folders  

La Folders Sidebar est principalement utilisée pour le contrôle de Browse des images.  

Cochez le menu View>Sidebar>Folders pour activer/afficher la Folders Sidebar.  

Cliquer sur son arbre permet de naviguer dans les répertoires de fichiers.  
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Double-cliquer sur le répertoire dans les Folders créera la fenêtre Browse. S'il y a des 

fichiers image dans le répertoire que ToupSky prend en charge pour Browse, les fichiers 

image seront affichés en mode Large ou Small icônes.  

Leur ordre peut être défini en Ascending ou Descending selon le Sort par Name, Type, 

Size, Width ou Height, etc.  

Cliquer avec le bouton droit de la souris sur le répertoire fera apparaître le menu 

contextuel comme indiqué ci-dessous :  

   
C'est le menu de l'explorateur de base et ne sera pas expliqué dans ce manuel.  

8.2.4 Sidebar>Undo/Redo  

La Undo/Redo Sidebar est utilisée pour lister les opérations Undo/Redo pour les 

commandes des menus Image et Process.  

Cochez le menu View>Sidebar>Undo/Redo pour activer/afficher la Undo/Redo Sidebar.  

8.3 Grille  

Le menu Grid a 5 sous-menus, ils sont :  

 8.3.1 Paramètres•••     

Choisir la commande View>Grid>Setting•••, ou choisir la commande Preference>••• et 
cliquer sur la page Grids réalise la même fonction.  
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Choisir la commande Option>Preference>••• et cliquer sur la page Grids permet de 

définir le Grid Style, Line Style, et Line Color pour la Grid superposée sur la fenêtre 

vidéo et image.  

Style : Le Grid Style peut être No Grid, Auto Grid ou Manual Grid. La valeur par défaut 
est No Grid ;  

Line Style : Le Line Style pour la grille peut être Solid, Dash, Dot ou DashDot, etc. La 

valeur par défaut est Solid ;  

Color : La couleur de la ligne de la grille. La valeur par défaut est Rouge (255,0,0).  

  
8.3.2 Grilles>Aucune Grille  

Choisir cette commande supprimera à la fois les Manual Grids et les Auto Grids 

superposées sur la fenêtre vidéo/image.  

8.3.3 Grilles>Grilles Automatiques  

Choisissez la commande Grids>Auto Grids pour superposer automatiquement les grilles 

sur la vidéo/image.  

Les Auto Grids peuvent être définies dans le menu View>Grids>Setting•••.  

8.3.4 Grilles>Grilles Manuelles  

Choisir cette commande affichera deux petites Right Arrow  et Down Arrow  superposées 

en haut de la Vertical Ruler et à gauche de la Horizontal Ruler comme indiqué ci-dessous 

: Down Arrow : Déplacer la souris sur la Down Arrow affichera une icône de glissement 

horizontal. Faites glisser la Down Arrow le long de la Horizontal Ruler jusqu'à l'endroit 

souhaité. Lorsqu'elle est glissée sur la vidéo/image, une ligne Vertical apparaîtra pour 
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vous permettre de juger où relâcher cette ligne sur la vidéo/image. Vous pouvez faire 

glisser n'importe quelles lignes pour les superposer sur la vidéo/image.  

Les lignes superposées peuvent être ajustées en faisant glisser à nouveau la Down 

Arrow spécifique sur la Horizontal Ruler.  

Right Arrow : Déplacer la souris sur la Right Arrow affichera une icône de glissement 

vertical . Faites glisser la Right Arrow le long de la Horizontal Ruler jusqu'à l'endroit 

souhaité. Lorsqu'elle est glissée sur la vidéo/image, une ligne Horizontal apparaîtra pour 

vous permettre de juger où relâcher cette ligne sur la vidéo/image. Vous pouvez faire 

glisser n'importe quelles lignes pour les superposer sur la vidéo/image.  

  
Les lignes superposées peuvent être ajustées en faisant glisser à nouveau la Right Arrow 

spécifique sur la Vertical Ruler.  

Choisissez la commande Grids>No Grid pour supprimer les Manual Grids superposées 

sur la fenêtre vidéo/image. Le menu sera coché.  

Choisissez à nouveau la commande Grids>Manual Grids (Si elle n'est pas cochée) pour 

afficher toutes les Manual Grids superposées précédemment sur la fenêtre vidéo/image. 

Le menu sera coché.  

8.3.5 Grilles>Supprimer Toutes les Grilles  

Supprimez (supprimez) toutes les Manual Grids ou Auto Grids superposées sur la fenêtre 

image/vidéo.  
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8.4 Ajustement Optimal   Num *  

Choisissez la commande View>Best Fit pour redimensionner automatiquement la 
vidéo/image afin qu'elle s'adapte à la fenêtre.  

Remarque : Choisir cette commande activera le menu View>Actual Size.  

8.5 Taille Réelle   Num /  

Remarque : Cette option sera désactivée si l'image est actuellement affichée à 100 %. 

À tout autre ratio de zoom, View>Actual Size sera activé.  

Choisissez la commande View>Actual Size pour définir l'image active à sa Actual Size 
(par exemple,  

100 %).  

8.6 Plein Écran      ESC  

Choisir la commande View>Full Screen affichera la fenêtre vidéo en mode plein écran. 

Appuyer sur le bouton ESC restaurera la fenêtre vidéo.  

8.7 Piste      

Remarque : Si la taille de la vidéo/image est plus petite que la taille de la fenêtre. 

L'opération de piste sera désactivée.  

Si la taille réelle de l'image est plus grande que la fenêtre vidéo/image, cochez cette 

commande pour positionner la vidéo/image qui ne tient pas entièrement dans la fenêtre 

vidéo/image. Sa fonction est similaire aux barres de défilement. C'est une alternative à 

l'utilisation des flèches sur les barres de défilement pour positionner la vidéo/image 

dans la fenêtre.  

Cocher le menu View>Track changera le curseur en  et le bouton de la barre d'outils 

sera coché.  

Ensuite, maintenez le bouton de la souris enfoncé pour faire glisser la région d'intérêt 

sur la vidéo/image à n'importe quel endroit dans la fenêtre vidéo/image.  
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8.8 Réticules  

Affichez les Crosshairs pour localiser l'étoile dans la fenêtre vidéo. Cliquez avec le bouton 

gauche de la souris sur la fenêtre vidéo pour déplacer les Crosshairs où vous le 

souhaitez.  

  
8.9 Cercle  

Affichez le Circle pour localiser l'étoile dans la fenêtre vidéo. Cliquez avec le bouton 

gauche de la souris sur la fenêtre vidéo pour déplacer le Circle où vous le souhaitez.  

  

8.10 Cercle avec Trou  

Affichez le Circle with Hole pour localiser l'étoile dans la fenêtre vidéo. Cliquez avec le 

bouton gauche de la souris sur la fenêtre vidéo pour déplacer le Circle with Hole où vous 

le souhaitez.  
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 9  Parcourir  
9.1 Trier  

9.1.1 Trier>Trier par Noms  

Cette commande est uniquement pour la fenêtre Browse.  

Sort les fichiers image par ordre de noms dans la fenêtre Browse.  

9.1.2 Trier>Trier par Type  

Cette commande est uniquement pour la fenêtre Browse.  

Sort les fichiers image par type de fichier dans la fenêtre Browse.  

9.1.3 Trier>Trier par Taille   

Cette commande est uniquement pour la fenêtre Browse.  

Sort les fichiers image par taille de fichier dans la fenêtre Browse.  

9.1.4 Trier>Trier par Largeur  

Cette commande est uniquement pour la fenêtre Browse.  

Sort les fichiers image par largeur de fichier image dans la fenêtre Browse.  

9.1.5 Trier>Trier par Hauteur  

Cette commande est uniquement pour la fenêtre Browse.  

Sort les fichiers image par hauteur de fichier image dans la fenêtre Browse.  

 9.1.6 Trier>Ascendant     

Cette commande est uniquement pour la fenêtre Browse.  

Sort les fichiers image dans l'ordre Ascending (c'est-à-dire 1, 2, 3 et 4) dans la fenêtre 

Browse.  

 9.1.7 Trier>Descendant     

Cette commande est uniquement pour la fenêtre Browse.  

Sort les fichiers image dans l'ordre Descending (c'est-à-dire 4, 3, 2 et 1) dans la fenêtre 

Browse.  
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Les paramètres de Sort sont sauvegardés jusqu'à ce qu'ils soient modifiés. Par exemple, 

si vous triez les images dans la fenêtre Browse selon le Type, les images resteront 

triées selon le Type jusqu'à ce que les paramètres de Sort soient modifiés.  

9.2 Icône  

 9.2.1 Icône>Grandes Icônes     

Cette commande est uniquement pour la fenêtre Browse.  

Le mode Thumbnail affiche de petites images de prévisualisation ; vous pouvez 

sélectionner différents modes d'affichage dans la fenêtre Browse.  

Choisir Icons>Large Icons affichera les fichiers image en mode Large Icon dans la 

fenêtre Browse.  

 9.2.2 Icône>Petites Icônes     

Cette commande est uniquement pour la fenêtre Browse.  

Le mode Thumbnail affiche de petites images de prévisualisation ; vous pouvez 

sélectionner différents modes d'affichage dans la fenêtre Browse.  

Choisir Icons>Small Icons affichera les fichiers image en mode Small Icon dans la 

fenêtre Browse.  

9.3 Rafraîchir    F5  

Cette commande est uniquement pour la fenêtre Browse.  

Si les fichiers sous le répertoire de la Folders Sidebar sont modifiés en dehors de 

ToupSky, après avoir basculé de retour vers ToupSky, vous pouvez Refresh les fichiers 

image dans le répertoire actuel pour mettre à jour les Thumbnails avec la commande 

Browse>Refresh.  

9.4 Propriétés•••      

Si un fichier image listé dans la fenêtre Browse est mis en surbrillance. Choisir la 

commande Browse>Properties ou cliquer sur le fichier sélectionné dans la fenêtre 
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Browse avec le menu contextuel du bouton droit de la souris Properties fera apparaître 

une boîte de dialogue Properties comme indiqué ci-dessous :  

  
La boîte de dialogue de fichier Properties comprend 3 pages. Elles sont General, 

Security et Details. Ces Property pages peuvent dépendre du système d'exploitation et 

nous n'en discuterons pas dans ce manuel d'aide. 
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Configuration  

10 Configuration   

10.1 Démarrer/Pause         Pause  

Si la vidéo dans la fenêtre vidéo est en cours de lecture, vous pouvez choisir la 

commande Setup>Start/Pause pour mettre la vidéo en pause et choisir à nouveau la 

commande Setup>Start/Pause pour redémarrer la vidéo.  

10.2 Afficher les Propriétés•••   Shift+V  

La commande Setup>View Property••• vous aidera à comprendre les propriétés 

statistiques du matériel de la caméra. Choisissez la commande Setup>View Property••• 

pour invoquer la boîte de dialogue View Property comme ci-dessous :  

  

Les éléments de la boîte de dialogue sont décrits comme suit :  

Device Name: Chaîne lisible pour identifier le nom de l'appareil photo ;  

Pixel Size : La taille actuelle des pixels de la caméra ;  

Still Image Capture: Pour identifier si la caméra prend en charge ou non la Still Image 

Capture. Still Image Capture est utilisée pour capturer une image avec une résolution 

différente de la vidéo avec une caméra haute résolution. Cette fonctionnalité est 

principalement utilisée pour capturer une image haute résolution sous une vidéo basse 

résolution pour un compromis entre la vitesse de trame et la résolution de l'image ;  

Video Width: La largeur réelle de la vidéo dans la fenêtre vidéo ;  

Video Height: La hauteur réelle de la vidéo dans la fenêtre vidéo ;  
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10.3 Test ST4  

La commande Setup>ST4 Test invoquera une boîte de dialogue ST4 pour tester le port 

ST4 de la caméra de guidage. Cliquez sur la touche flèche pour tester si cela fonctionne. 

La zone de saisie centrale peut entrer  

Configuration  

le temps pour le test.  
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11 Capturer  

11.1 Capturer une Image      F8  

Pendant la prévisualisation vidéo, vous pouvez toujours choisir la commande 

Capture>Image Capture pour capturer l'image vidéo.  

Après que l'image est capturée, l'image capturée deviendra la fenêtre active actuelle. 

Le menu Capture>Capture Image sera désactivé. Si vous souhaitez capturer l'image à 

nouveau, cliquez sur le titre de la fenêtre vidéo pour activer la fenêtre vidéo et le menu 

Capture>Capture Image sera à nouveau activé.  

Remarque : a) Le bouton « Snap »  sur la Camera Sidebar peut capturer 

continuellement l'image même si la fenêtre vidéo n'est pas activée. L'utilisateur peut 

cliquer sur ce bouton sur la Camera Sidebar pour capturer une image rapidement ;  b) 

Seulement lorsque la fenêtre vidéo est active, le menu Capture>Capture Image sera 

activé ; c) Si les résolutions Live et Snap sont différentes, ToupSky doit passer de la 

résolution Live à la résolution Snap en arrière-plan pour capturer une image avec la 

résolution Snap. Après que le Snap est terminé, ToupSky reviendra à la résolution Live 

pour continuer le processus de flux vidéo. Cela prendra plus de temps pour capturer 

une image fixe.  

11.2 Capture Automatique       F7  

Choisir la commande « Capture>Auto Capture » ou appuyer sur le bouton de la barre 

d'outils  commencera à capturer l'image du flux vidéo automatiquement.   

Après avoir commencé à capturer, le « Capture>Auto Capture » changera en « 
Capture>Stop  

Capture » et le bouton de la barre d'outils  sera coché.  

Choisir la commande « Capture>Stop Capture » ou appuyer sur le bouton de la barre 

d'outils coché  arrêtera le processus de capture automatique.  
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Le menu « Capture>Stop Capture » changera en « Capture>Auto Capture » et le 
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bouton de la barre d'outils  sera décoché.  

La commande Auto Capture nécessite de définir certains paramètres prédéfinis. Cela 

peut être fait dans la page de propriétés Options>Preferences•••>Auto Capture :  

  
Directory : Entrez le nom du lecteur et du répertoire où la nouvelle image sera 
sauvegardée.  

Vous pouvez soit taper les informations du chemin, soit utiliser le bouton Browse  

pour le localiser depuis une boîte de dialogue Browse Folder standard ;  

Name Format : Les year, month, date, hour, minute et second ou nnnn(sequence) sont 

utilisés comme partie du nom de fichier. Si plusieurs fichiers sont sauvegardés en une 

seconde, un suffixe (xx) est ajouté à la fin de Name Format pour éviter les conflits de 

nom. Pour le nnnn(sequence) Name Format, aucun suffixe n'est nécessaire.  

File Prefix : Entrez un préfixe de nom de fichier pour Auto Capture lors de la génération 

de noms de fichiers pour une série d'images. Ce préfixe sera combiné avec Name 

Format pour former un nom de fichier final selon le paradigme de nommage.  

File Type : Dans cette combobox, sélectionnez le format dans lequel vous souhaitez 

enregistrer l'image (peut être BMP, JPG, PNG, TIF, FIT) ;  

Sample : Le nom de fichier final est affiché à droite de l'étiquette Sample pour référence 
;  
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Capture every frame : Cocher cet élément capturera chaque image de la séquence 
vidéo ;  

Time Slot(second) : Capturez une image selon l'intervalle de temps (0-100S, la valeur 
par défaut est 6) ;  

Total Images : Cochez Total Images activera sa zone de saisie. Vous pouvez entrer le 

nombre total d'images Total Images (1-9999, la valeur par défaut est 100) à capturer. 

ToupSky arrêtera automatiquement le processus Auto Capture lorsque le nombre total 

d'images Total Images sera atteint ;  

Si Total Images n'est pas coché, ToupSky capturera les images en continu jusqu'à ce 

que l'utilisateur choisisse à nouveau la commande Capture>Stop Capture pour arrêter 

le processus Auto Capture.  

Après que le Auto Capture est commencé, le menu Capture>Auto Capture sera 

changé en menu Capture>Stop Capture. Choisir cette commande arrêtera le 

processus Auto Capture.  

Il existe une variété de formats d'image disponibles (ils sont bmp, jpg, png, tif ou fit) 

pour enregistrer l'image capturée. Par exemple, en choisissant le format jpg, les options 

de sauvegarde peuvent être définies dans la page de propriétés 

Options>Preferences•••>File. Si le format a des options à définir, le bouton Config••• 

sera activé.   

  
Cliquer sur le bouton Config••• fera apparaître une boîte de dialogue comme ci-

dessous. Différents formats ont différentes options.  
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Après que tous les paramètres sont définis. Cliquez sur OK pour fermer la boîte de 

dialogue et les paramètres peuvent être utilisés pour la commande Auto Capture sans 

configuration supplémentaire pour accélérer le processus de capture.  

  

11.3 Démarrer l'Enregistrement       F9  

Cette commande commencera à enregistrer la vidéo selon les paramètres dans  

la page de propriétés Options>Preference>Record (voir la section 14.1.1)  

  
1. Vous pouvez a) choisir la commande Capture>Start Record••• ; b) cliquer sur le 

bouton « Record »  

 sur la Camera Sidebar ; c) utiliser la touche de raccourci « F9 » pour 
commencer à enregistrer  

des vidéos.   
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2. Après que l'enregistrement vidéo a commencé. Le bouton  sur la 
Camera Sidebar  

deviendra . Cliquer sur  arrêtera le processus de capture, 

sinon, il s'arrêtera jusqu'à ce que la Time Limit dans la page 

Options>Preference>Record soit atteinte. Après la fin du processus 

d'enregistrement vidéo. Le  sur la  

Camera Sidebar redeviendra  pour le futur processus Record ;  

L'utilisateur peut choisir la commande File>Open Video••• pour afficher le fichier vidéo 

capturé dans la fenêtre vidéo ;  

Après que le Capture>Start Record est en cours, le menu Capture>Batch Record ou le 

bouton Batch Record sur la barre d'outils seront désactivés.  

11.4 Enregistrement par Lots       (F10)  

Commencez à enregistrer la vidéo en mode batch. Cette commande permettra à 

l'utilisateur d'enregistrer la vidéo rapidement. Les paramètres de Batch Record sont 

définis dans les pages de propriétés Options>Preferences•••>Record et 

Options>Preferences•••>Batch Record (voir les sections 14.1.1 et 14.1.2) pour plus 

de détails.  
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Après que le Batch Record commence, l'application commencera à enregistrer la 1ère 

vidéo jusqu'à ce que la condition d'arrêt soit atteinte (voir 

Options>Preferences•••>Record).  

Ensuite, après que l'intervalle de temps Time interval soit atteint dans la page 

Options>Preferences•••>Batch Record, l'application commencera à enregistrer la 

2ème ou la prochaine vidéo.  

Le Batch Record s'arrêtera jusqu'à ce que le nombre Number soit atteint dans la page 

Options>Preferences•••>Batch Record.  

Après que le Batch Record commence, le menu Capture>Start Record sera changé en 

menu Capture>Stop Record (le bouton  sur la Camera Sidebar changera 

en ) et le menu Batch Record et le bouton de la barre d'outils  seront 

désactivés. L'utilisateur peut choisir le menu Capture>Stop Record ou cliquer sur le 

bouton  pour arrêter le processus d'enregistrement actuel.   

Remarque, cette commande n'arrêtera pas le processus Batch Record, après que la 

condition de l'intervalle de temps Time interval dans la page 

Options>Preferences•••>Batch Record soit atteinte, l'application commencera à 

enregistrer la prochaine image jusqu'à ce que le nombre Number dans la page 

Options>Preferences•••>Batch Record soit atteint.  
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Pour arrêter le processus Batch Record entier, seulement lorsque l'enregistrement 

précédent est arrêté ou terminé et que le prochain enregistrement ne commence pas, 

dans cet intervalle, le  sera activé, cliquez dessus pour arrêter tout le processus 

Batch Record. 
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12 Image  
12.1 Mode  

12.1.1 Quantification des Couleurs•••  

La commande Color Quantize••• est largement utilisée pour changer les bits de l'image. 

ToupSky prend en charge les changements mutuels entre les images 24 bit, 8 bit, 4bit 

ou 1 bit.  

Lorsque la boîte de dialogue Colour Bits est ouverte, les 

bits de couleur cochés par défaut sont les bits de couleur 

de l'image actuelle. Cochez les bits désirés et cliquez sur 

OK pour terminer la commande. L'image sera convertie 

aux bits de couleur sélectionnés dans la fenêtre 

d'image.   

12.1.2 Niveaux de Gris  

Choisissez la commande Gray Scale pour convertir une image couleur (image couleur 

vraie ou image couleur indexée) en image en niveaux de gris. Si l'image originale est 

de 24 bits, la nouvelle image est de 8 bits. Sinon, les bits de l'image ne seront pas 

modifiés.  

12.1.3 Découleurisation Préservant le Contraste  

Choisissez la commande Image>mode>Contrast Preserving Decolorization pour 

convertir l'image couleur en image en niveaux de gris avec conservation du contraste. 

Les images suivantes (a) sont l'image microscopique originale, (b) est l'image en 

niveaux de gris produite par la méthode traditionnelle, (c) est l'image en niveaux de gris 

produite par la Découleurisation Préservant le Contraste.  

  
(a) Image microscopique originale  
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(b) Méthode traditionnelle    (c) Découleurisation Préservant le Contraste  

12.2 Ajuster  

12.2.1 Luminosité/Contraste•••  

La commande Image>Adjustment>Brightness/Contrast••• offre des ajustements 

simples de la gamme tonale d'une image. Cette commande effectue le même 

ajustement pour chaque pixel de l'image. La commande Brightness/Contrast ne 

fonctionne pas avec des canaux individuels et n'est pas recommandée pour les sorties 

haut de gamme car elle peut entraîner une perte de détails sur l'image.  

  
Brightness : Faire glisser la barre de défilement vers la gauche diminue le niveau et la 

faire glisser vers la droite augmente le niveau. Les chiffres à droite de la barre de 

défilement affichent la valeur de Brightness. Les valeurs peuvent varier de -100 à 

+100. La valeur par défaut est 0 ;  

Contrast : Faire glisser la barre de défilement vers la gauche diminue le niveau et la 

faire glisser vers la droite augmente le niveau. Les chiffres à droite de la barre de 

défilement affichent la valeur de Contrast. Les valeurs peuvent varier de -100 à +100. 

La valeur par défaut est 0 ;  

12.2.2 Couleur•••  

Choisissez la commande Image>Adjustment>Color••• pour modifier le mélange global 

des couleurs d'une image.  

Il existe quatre modules de couleur : RGB, CMYK, HIS et HLS.  
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RGB: ToupSky utilise le modèle RGB. Il attribue une valeur d'intensité à chaque pixel 

allant de 0 (noir) à 255 (blanc) pour chacun des composants RGB dans une image 

couleur. Par exemple, une couleur rouge vif peut avoir une valeur R de 246, une valeur 

G de 20 et une valeur B de 50. Lorsque les valeurs des trois composants sont égales, le 

résultat est une teinte de gris neutre. Lorsque la valeur de tous les composants est de 

255, le résultat est un blanc pur ; lorsque la valeur est de 0, un noir pur.  

Les images RGB utilisent 3 canaux pour reproduire jusqu'à 16,7 millions de couleurs à 

l'écran. En plus d'être le mode par défaut pour les nouvelles images ToupSky, le mode 

RGB est utilisé par les moniteurs d'ordinateur pour afficher les couleurs. Cela signifie 

que lorsque vous travaillez dans des modes de couleur autres que RGB, tels que CMYK, 

ToupSky utilise le mode RGB pour l'affichage à l'écran.  

Bien que RGB soit un mode de couleur standard, la gamme exacte de couleurs 

représentées peut varier, selon l'application ou le dispositif d'affichage.  

CMYK: Le mode CMYK est basé sur la qualité d'absorption de la lumière des encres 

imprimées sur papier. Lorsque la lumière blanche frappe des encres translucides, 

certaines longueurs d'onde visibles sont absorbées tandis que d'autres sont réfléchies 

vers les yeux.  

   
En théorie, des pigments de cyan pur (C), magenta (M) et jaune (Y) devraient se 

combiner pour absorber toute la lumière et produire du noir. Pour cette raison, ces 

couleurs sont appelées couleurs soustractives. Parce que toutes les encres d'impression 
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contiennent des impuretés, ces trois encres produisent en réalité un brun boueux et 

doivent être combinées avec de l'encre noire (K) pour produire un vrai noir. (K est utilisé 

à la place de B pour éviter la confusion avec le bleu.) Combiner ces encres pour 

reproduire les couleurs est appelé impression en quadrichromie.  

Les couleurs soustractives (CMY) et additives (RGB) sont des couleurs complémentaires. 

Chaque paire de couleurs soustractives crée une couleur additive, et vice versa.  

HSI: Basé sur la perception humaine des couleurs, le modèle HSI décrit 3 

caractéristiques fondamentales des couleurs :  

  
Hue est la couleur réfléchie ou transmise à travers un objet. Elle est mesurée comme 

une position sur la roue chromatique standard, exprimée en degrés entre 0° et 360°. 

Dans l'usage courant, Hue est identifié par le nom de la couleur telle que rouge, orange 

ou vert.  

Saturation, parfois appelée chroma, est la force ou la pureté de la couleur. Saturation 

représente la quantité de gris par rapport à la teinte, mesurée en pourcentage de 0 % 

(gris) à 100 % (complètement saturé). Sur la roue chromatique standard, Saturation 

augmente du centre vers le bord.   

Intensity est la clarté ou l'obscurité relative de la couleur, généralement mesurée en 

pourcentage de 0% (noir) à 100% (blanc).  

HLS: Le modèle HLS est très similaire au modèle de couleur HLS. La principale différence 

entre eux est le calcul utilisé pour produire la valeur de luminosité. Dans le modèle HLS, 

la luminosité d'un pixel (L) est dérivée de ses trois valeurs de couleur (R, G et B). Dans 

le modèle HLS, la luminosité d'un pixel (L) est déterminée par les valeurs minimales et 

maximales de ses trois valeurs de couleur.  
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Les valeurs à côté de la barre de défilement montrent les changements de couleur dans 
divers canaux de couleur.  

Pour les valeurs des canaux RGB, elles vont de -100 à +100. La valeur par défaut est 0 
;  

Pour les valeurs des canaux CMYK, elles vont de -100 à +100. La valeur par défaut est 
0 ;  

Pour les valeurs des canaux HSI, la valeur H peut aller de -180 à 180, la valeur S va de 
-275 à 275, et la valeur I va de -442 à 442. La valeur par défaut est 0 ;  

Pour les valeurs des canaux HLS, la valeur H va de -180 à 180, la valeur L va de -100 à 

100, et la valeur S va de -100 à 100. La valeur par défaut est 0 ;  

12.2.3 HMS•••  

Choisissez la commande Image>Adjustment>HMS••• pour ajuster les parties HL 

(Highlight), M (Midtone), et S (Shadow) de l'image. La valeur de chaque partie varie de 

-100 à 100. Cette commande est uniquement disponible pour une image en vraie 

couleur 24 bits.  

  
12.2.4 Courbe•••  

Choisissez la commande Image>Adjust>Curve••• pour ajuster la gamme tonale entière 

d'une image. Mais au lieu de faire des ajustements en utilisant seulement trois variables 

(Highlight, Midtone, Shadow), on peut ajuster n'importe quel point sur la courbe le long 

d'une échelle de 0 à 255 tout en gardant jusqu'à d'autres valeurs constantes. On peut 
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également utiliser Curve pour faire des ajustements précis pour les canaux de couleur 

individuels sur une image. La boîte de dialogue Curve est montrée ci-dessous :  

  

Horizontal Axis: L'axe horizontal du graphique représente les valeurs d'intensité 

originales des pixels (Input niveaux).  

Vertical Axis: L'axe vertical représente les nouvelles valeurs de couleur (Output 
niveaux). Dans la ligne diagonale par défaut, tous les pixels ont des valeurs Input et 
Output identiques.  

Curve area: Zone (spécifiée avec le blue rectangle) pour configurer une carte entre 

l'entrée et la sortie ;  

a) Lorsque vous ouvrez la boîte de dialogue Curve, vous voyez, peut-être 

étonnamment, non pas une courbe mais une ligne droite. Par défaut, les valeurs 

d'entrée sont les mêmes que les valeurs de sortie, donc il n'y a pas de changement 

;  

b) En cliquant au centre de la ligne et en la tirant vers le haut, nous créons notre 

première courbe. Augmenter la courbe augmente la luminosité globale de la scène.  

c) Inversement, cliquer au centre et tirer vers le bas diminue la luminosité, 

produisant une image globalement plus sombre ;  

d) En plus de cliquer au centre, nous pouvons également ajuster les points de 

terminaison. Cliquer sur le point en haut à droite et le tirer vers le bas limite la 

partie la plus lumineuse de l'image, réduisant le contraste.  
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e) Si nous déplaçons ce point en haut à droite vers la gauche plutôt que vers le 

bas, nous produisons l'effet opposé - augmentant le contraste de l'image. Ceci est 

une correction rapide très utile et contrôlable ;  

f) En tirant les points en haut et en bas vers le centre, nous créons un effet 

stylisé, posterisé, qui transforme toute photographie en un objet graphique.  

g) Cliquez une fois au centre de la courbe RVB pour "épingler" ce point central ; 

maintenant tirez juste la moitié supérieure de la courbe pour faire cette forme en 

S, et le résultat est d'augmenter le contraste global.  

h) Vous pouvez ajouter jusqu'à n'importe quel point de contrôle à la courbe, 

verrouillant ces valeurs. Pour supprimer un point de contrôle, 1) tirez-le hors du 

graphique ou 2) cliquez avec le bouton droit de la souris sur ce point. Vous ne 

pouvez pas supprimer les points de terminaison de la courbe.  

 

 
B) à partir du bouton Channel. Cochez le bouton blanc pour sélectionner les canaux RGB 

en même temps, qui se trouve à gauche des boutons R (Rouge), G (Vert) et B (Bleu) ;  

Curve : Cliquez sur la Curve avec votre bouton gauche de la souris, une courbe spline 

(ligne droite) configurera la relation d'entrée-sortie initiale. Cliquez sur la Curve pour 

marquer la Curve avec un point. Le nombre de points peut être quelconque tant qu'il 

peut être inséré sur la Curve. Faites glisser le marked point jusqu'à ce que l'image soit 

satisfaisante. Le point peut être supprimé en déplaçant la souris dessus et en cliquant 

dessus avec le bouton droit de la souris.   

a)  b)  c)  d)  

e)   f)  g)  h)  

Grille:  Cochez pour superposer la grille sur la fenêtre 
de la  

courbe   fenêtre ;  

Canal  :   Pour ajuster la balance des couleurs de l'image, cochez le canal ( R ,  G  ou  
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Pencil : Cochez le bouton crayon en bas de la boîte de dialogue, et utilisez votre 

bouton gauche de la souris pour dessiner une nouvelle Curve arbitraire dans la zone de 

la Curve.  

Reset: Cliquez sur le bouton Reset pour réinitialiser la Curve à la ligne droite initiale.  

Apply: Appliquer la carte de Curve actuelle sur l'image.  

12.2.5 Filtre de Couleur•••  

Choisissez la commande Image>Adjustment>Filter Color pour filtrer un canal de couleur 

spécial à partir d'une image couleur. Cochez soit la couleur Red, Green, ou Blue à filtrer. 

Pour chaque pixel, si vous cochez la couleur Red à filtrer, seules les informations 

concernant le canal rouge seront supprimées, et les informations Green et Blue 

resteront.  

  

Voir Image>Extract Color••• pour une autre opération de couleur.  

12.2.6 Extraire la Couleur•••  

Choisissez la commande Image>Adjustment>Extract Color••• pour extraire un canal de 

couleur spécial à partir d'une image couleur. Cochez soit la couleur Red ou Green, ou 

Blue à extraire.   

Pour chaque pixel, si vous sélectionnez la couleur Red à extraire, seules les informations 

concernant le canal rouge seront conservées, et les informations Green et Blue seront 

supprimées.  

  

Voir Image>Filter Color••• pour une autre opération de couleur.  
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12.2.7 Inverser  

Choisissez la commande Image>Adjustment>Invert pour inverser les valeurs de pixels 

de l'image active sans passer par la table de correspondance.  

12.2.8 Lissage Préservant les Bords•••  

Edge Preserving Smooth est une technique de traitement d'image qui lisse les textures 

tout en conservant les bords nets. Les exemples sont le filtre bilatéral, le filtre guidé et 

la diffusion anisotrope.  

Choisissez la commande Image>Adjust>Edge Preserving Smooth••• pour lisser toute 

l'image et conserver le bord de l'image, comme indiqué ci-dessous :  

  
La fonction Edge Preserving Smooth propose deux types de filtres, y compris le filtre 

Recursive et le filtre de Normalized Convolution, et le filtre par défaut est Recursive.   

ToupSky utilise Spatial Sigma et Range Sigma pour définir la taille du noyau du filtre. 

Plus les deux paramètres sont grands, plus l'image est lissée, et vice versa.  

12.2.9 Amélioration des Détails•••  

Choisissez la commande Image>Adjust>Detail Enhance••• pour améliorer les détails de 

l'image, comme indiqué ci-dessous :  
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ToupSky choisit Spatial Sigma et Range Sigma pour définir la taille du noyau de 

l'algorithme d'amélioration des détails. Plus les 2 paramètres sont grands, plus l'image 

est améliorée et vice versa.  

L'image suivante est l'image améliorée des détails pour référence avec le paramètre par 
défaut.  

  
a) Image originale et b) Image améliorée  

12.3 Rotation  

Choisissez la commande Image>Rotate pour faire pivoter l'image entière. On a les sous-

menus suivants :  

12.3.1 90 (CW)  

Faites pivoter l'image dans le sens des aiguilles d'une montre d'un quart de tour.  

12.3.2 180 (CW)  

Faites pivoter l'image de 180 degrés dans le sens des aiguilles d'une montre.  

12.3.3 270 (CW)  

Faites pivoter l'image de 270 degrés dans le sens des aiguilles d'une montre.  

12.3.4 Angle Arbitraire•••  

Faites pivoter l'image d'un angle spécifié. Si vous choisissez cette option, entrez un 

angle entre 0 et 360 degrés dans la zone de texte de l'angle, et cochez CW ou CCW 

pour faire pivoter dans le sens des aiguilles d'une montre ou dans le sens inverse. 

Pour l'opération Arbitrary•••, cela invoquera une boîte de dialogue Image Rotate 

comme ci-dessous :  
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Degree : Le degré auquel l'image doit être tournée.  

CW : Fait pivoter l'image dans le sens des aiguilles d'une montre.  

CCW : Fait pivoter l'image dans le sens inverse des aiguilles d'une montre.  

Quality : On peut sélectionner l'une des trois méthodes pour la rotation de l'image parmi 

Nearest Neighbor, Bilinear, et Bicubic. La valeur par défaut est Bilinear.  

12.3.5 Retourner Horizontalement      

Inverse l'image dans la zone d'application de sorte que le coin supérieur droit de l'image 

originale soit maintenant le coin supérieur gauche, et le coin supérieur gauche de l'image 

originale soit maintenant le coin supérieur droit.  

12.3.6 Retourner Verticalement       

Inverse l'image dans la zone d'application de sorte que le coin supérieur droit de l'image 

originale soit maintenant le coin inférieur droit, et le coin supérieur gauche de l'image 

originale soit maintenant le coin inférieur gauche.  

12.4 Rogner       Shift+C   

Choisissez la commande Image>Crop pour supprimer les parties d'une image que vous 

ne souhaitez pas afin que l'accent soit mis sur la partie restante de l'image. Ce document 

explique aux utilisateurs comment Crop une image dans ToupSky.  

1. Choisissez la commande Open Image••• pour ouvrir une image à Crop ;  

2. Choisissez la commande Edit>Image Select ou cliquez sur le bouton Image Select 

 sur la Toolbar, le curseur changera en une petite croix.  
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3. Déplacez le curseur sur l'image à l'emplacement souhaité, cliquez sur le bouton de la 

souris et maintenez-le enfoncé pour marquer la première position.  

4. Faites glisser la souris sur la partie de l'image à conserver, un rectangle pointillé 

apparaît autour de la sélection et relâchez le bouton gauche de la souris.  

5. Optionnel 1 : Pour déplacer le rectangle : a) Déplacez la souris sur la zone 

sélectionnée et lorsqu'elle devient un curseur de déplacement, cliquez et maintenez 

le bouton gauche de la souris ; b) Faites glisser la zone sélectionnée à l'emplacement 

souhaité.  

  
6. Optionnel 2 : Pour changer la taille du rectangle : a) Mettez le curseur de la souris 

sur l'une des poignées qui apparaissent sur les bords de la zone sélectionnée ; b) 

Cliquez et maintenez le bouton de la souris ; c) Faites glisser la boîte à la taille 

souhaitée.  

Remarque : Chacune des poignées qui apparaissent sur les bords de la boîte 

redimensionne la boîte différemment. 7. Pour Crop l'image, choisissez la commande 

Image>Crop ou appuyez sur les boutons Shift+C. Remarque : Si la zone sélectionnée 

est sur la vidéo, choisir la commande Image>Crop capturera la zone sélectionnée et 

l'affichera dans une nouvelle fenêtre d'image.   
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12.5 Mise à l'Échelle de l'Image•••     

Choisissez la commande Image>Image Scale••• pour changer l'image à une taille 

spécifiée. Ce processus modifie en réalité la résolution spatiale en ajoutant (répliquant) 

ou supprimant (décimant) des pixels pour atteindre les dimensions spécifiées.  

Width et Height : En choisissant la commande Image Scale, la boîte de dialogue affiche 

les dimensions de l'image originale en pixels. Les Width et Height peuvent être définis 

sur la nouvelle image en ajoutant ou en supprimant des pixels. Si Constrain Proportions 

est coché, les Width et Height resteront proportionnels les uns aux autres. Si Constrain 

Proportions n'est pas coché, les Width et Height peuvent être définis indépendamment, 

mais cela déformera l'image.  

  
Reset : Réinitialise la Width et la Height de l'image à celles d'origine.  

Constrain Proportions : Pour maintenir les proportions actuelles de Width et Height en 

pixels, cochez Constrain Proportions. Cette option met automatiquement à jour la Width 

lorsque la Height est modifiée, et vice versa. Sinon, décochez le bouton Constrain 

Proportions.  

Scale method : Il y a 3 options pour le Scale method. Elles sont : Nearest Neighbor, 

Bilinear, et Bicubic. La valeur par défaut est Bilinear.  

12.6 Histogramme•••       Shift+H  

Un Histogram illustre comment les pixels dans une image sont distribués en traçant le 

nombre de pixels à chaque niveau d'intensité de couleur. L'Histogram montre si l'image 

contient suffisamment de détails dans les Shadows (indiqués dans la partie gauche de 

l'Histogram), les Midtones (indiqués au milieu), et les Highlights (indiqués dans la partie 

droite) afin d'apporter une bonne correction.  
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L'Histogram donne également une image rapide de la gamme tonale de l'image, ou du 

type de clé de l'image. Une image à faible tonalité a des détails concentrés dans les 

ombres, une image à haute tonalité a des détails concentrés dans les hautes lumières, 

et une image à tonalité moyenne a des détails concentrés dans les Midtones. Une image 

avec une gamme tonale complète a un nombre de pixels dans toutes les zones. Identifier 

la gamme tonale aide à déterminer les corrections tonales appropriées.  

Choisissez la commande Image>Histogram••• pour ouvrir la boîte de dialogue 

Histogram comme indiqué ci-dessous.  

En fonction du mode de couleur de l'image, choisissez R, G et B, ou Luminosity pour voir 

un Histogram composite de tous les canaux.  

Si l'image est en vraie couleur RGB, choisissez Luminosity pour afficher un Histogram 
représentant les valeurs de luminance ou d'intensité du canal composite.  

    

    
Si l'image est en vraie couleur RGB, choisissez R, G et B pour afficher un Histogram 

composite des canaux de couleur individuels en couleur.  

Faites l'une des actions suivantes :  

Pour voir des informations sur une valeur de pixel spécifique, placez le pointeur de la 

souris dans l'Histogram.  
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Pour voir des informations sur une plage de valeurs, cliquez sur le bouton gauche de la 

souris et faites-le glisser dans l'Histogram pour surligner la plage.  

La boîte de dialogue affiche les informations statistiques suivantes sous l'Histogram :  

Pixels : Représente le nombre total de pixels utilisés pour calculer l'Histogram.  

Level : Affiche le niveau d'intensité de la zone sous le pointeur.  

Count : Affiche le nombre total de pixels correspondant au niveau d'intensité sous le 

pointeur.  

Percentile : Affiche le nombre cumulatif de pixels au niveau ou en dessous du niveau 

sous le pointeur. Cette valeur est exprimée en pourcentage de tous les pixels de l'image, 

de 0% à l'extrême gauche à 100% à l'extrême droite.



Process  

79  

13 Processus  

13.1 Assemblage•••       Shift+T  

L'assemblage d'images ou l'assemblage de photos est le processus de combinaison de 

plusieurs images photographiques avec des champs de vision qui se chevauchent pour 

produire un panorama segmenté ou une image haute résolution. Souvent réalisé à 

l'aide de logiciels informatiques, la plupart des approches de l'assemblage d'images 

nécessitent des chevauchements presque exacts entre les images et des expositions 

identiques pour produire des résultats homogènes. Certaines caméras numériques 

peuvent assembler leurs photos en interne. L'assemblage d'images est largement 

utilisé dans le monde d'aujourd'hui dans des applications telles que la fonctionnalité 

"Stabilisation d'Image" dans les caméscopes qui utilisent l'alignement des images à la 

cadence, les mosaïques photo haute résolution dans les cartes numériques et les photos 

satellites, l'imagerie médicale, la super-résolution multi-images, l'assemblage vidéo et 

l'insertion d'objets.  

ToupSky a également intégré cette fonction. Il inclut Video Stitch, Image Stitch et 

Browse Window Stitch.  

13.1.1 Assemblage Vidéo  

Lorsque la fenêtre vidéo est active, choisir la commande Process>Stitch••• invoquera la 

boîte de dialogue vidéo Stitch comme ci-dessous :  

Capturer des Images  
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Snap: Cliquez pour capturer l'image de la caméra. On doit essayer de déplacer le 

curseur à une position appropriée pour capturer les images souhaitées. Dans le 

processus de déplacement, la prochaine image doit avoir une certaine zone de 

chevauchement avec l'image précédente à gauche ou en haut pour assurer le succès 

du processus d'assemblage.  

Reset: Lorsqu'une image ou des images sont capturées, le bouton Reset sera activé, 

cliquez sur Reset pour les supprimer de la mémoire ˗ Il sera désactivé lorsqu'il n'y a 

pas d'image capturée ;   

Snap: Les images capturées de la caméra ;  

Cancel: Cliquez pour annuler le processus d'assemblage ;  

Next> : Cliquez sur Next> pour passer à l'étape suivante ;  

Finish : Cliquez sur Finish pour accepter les autres paramètres par défaut et commencer 

à assembler les images capturées selon les paramètres ci-dessus.  

Méthode d'Assemblage  

  

Panorama Straighten : La direction de l'assemblage des images. Elle peut être 

Horizontal, Vertical ou None. La valeur par défaut est Horizontal ;  

Projection Type : Pour les segments d'image qui ont été pris du même point dans 

l'espace, les images assemblées peuvent être arrangées en utilisant l'une des diverses 

projections cartographiques. ToupSky inclut les projections cartographiques Plane, 
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Cylindrical, Spherical, Fisheye, Stereographic, Mercator ou Transverse Mercator. La 

valeur par défaut est Cylindrical ;  

Seam Finder : Méthode de détection de couture, ToupSky inclut None, Voronoi 

Diagram, Graph Cut Color ou Graph Cut Color Grad. La valeur par défaut est Graph 

Cut Color ;  

Exposure Compensation : Exposure Compensation est nécessaire entre les images pour 

minimiser les différences d'exposition. ToupSky inclut les méthodes None, Gain ou 

Blocks Gain Exposure Compensation. La valeur par défaut est Blocks Gain ;  

Bundle Adjust : L'ajustement par faisceau peut être défini comme le problème de 

raffiner simultanément les coordonnées 3D décrivant la géométrie de la scène ainsi que 

les paramètres du mouvement relatif et les caractéristiques optiques de la ou des 

caméras utilisées pour acquérir les images, selon un critère d'optimalité impliquant les 

projections d'image correspondantes de tous les points. ToupSky inclut les méthodes 

d'ajustement Ray adjust ou Reprojection error. La valeur par défaut est Ray adjust ;  

<Back : Cliquez sur <Back pour revenir à la page de configuration précédente ;  

Next>: Cliquez sur Next> pour passer à l'étape suivante ;   

Finish : Cliquez sur Finish pour accepter les autres paramètres par défaut et commencer 

à assembler les images selon les paramètres ci-dessus ;  

Cancel: Cliquez pour annuler le processus d'assemblage ;  

Paramètre d'Assemblage  
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Match Confidence : 1~100, la valeur par défaut est 65 ;  

Panorama Confidence : 1~100, la valeur par défaut est 100 ;  

Match Strength : 0~100, la valeur par défaut est 25 ;  

Blend Strength : 0~100, la valeur par défaut est 5 ;  

Defaults : Cliquez sur Defaults pour définir tous les paramètres sur ceux par défaut.  

<Back: Cliquez sur <Back pour revenir à l'étape précédente ;  

Finish : Cliquez sur Finish pour commencer à assembler les images selon les paramètres 

ci-dessus. Après avoir cliqué sur le bouton Finish, ToupSky commencera à assembler 

et une boîte de dialogue de progression sera affichée pour indiquer l'avancement du 

processus.  

Cancel: Cliquez pour annuler le processus d'assemblage ;  

  
L'image assemblée finale sera créée dans une nouvelle fenêtre d'image.  
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Dans l'image assemblée, il y a des zones noires ; celles-ci se produisent lorsqu'il y a des 

translations entre les images de bord dans les deux directions.  

13.1.2 Assemblage d'Images  

Si des images sont ouvertes dans ToupSky, par exemple 0001.jpg, 0002.jpg, 0003.jpg, 

0004.jpg sont ouvertes comme indiqué ci-dessous :  

  

Choisir la commande Process>Stitch invoquera la boîte de dialogue Stitch comme 

indiqué ci-dessous :  
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 a)  Available Images and b) Selected Images  

Available Images: Les images ouvertes par ToupSky˗ Ici, 4 images sont listées dans la 

liste déroulante. On peut cliquer sur le nom du fichier image pour sélectionner les 

fichiers à ajouter aux Images sélectionnées ;  

Selected Images: Les images sélectionnées pour l'assemblage˗ En utilisant Add>> pour 
ajouter les Available  

Images à cette liste déroulante ;  

Add>> : Lorsqu'une ou des images sont sélectionnées et mises en surbrillance dans la 

fenêtre Available Images, le bouton Add>> sera activé. Cliquez sur Add>> pour les 

ajouter dans la liste Selected Images˗  

Add All>> : Cliquez sur Add All>> pour ajouter toutes les Available Images dans la 

liste Selected Images ;  

Remove : Lorsqu'une ou des images sont sélectionnées et mises en surbrillance dans 

la liste Selected Images, le bouton Remove sera activé, cliquez sur Remove pour les 

retirer de la liste Selected Images˗  

Clear : Utilisé pour effacer toutes les images dans la liste Selected Images. 

Lorsqu'aucune image n'est dans la liste Selected Images, il sera désactivé˗  

Cancel: Cliquez pour annuler le processus d'assemblage ;  

Finish : Cliquez sur Finish pour accepter les autres paramètres par défaut et commencer 

à assembler les images capturées selon les paramètres ci-dessus ;  

Next> : Cliquez sur Next> pour passer à l'étape suivante ;  
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Les autres étapes Next> sont identiques à celles du processus Video Stitch.  

L'image finale assemblée sera créée dans une nouvelle fenêtre d'image comme indiqué 
ci-dessous :  

  

L'image assemblée  

Dans l'image assemblée, il y a des zones noires ; celles-ci se produisent lorsqu'il y a des 

translations entre les images de bord dans les deux directions.  

13.1.3 Assemblage de la fenêtre de navigation  

Cliquez sur Folders Sidebar pour l'activer. Double-cliquez sur le bon répertoire pour 

afficher les images sous le répertoire dans la fenêtre Browse. Choisissez les fichiers 

image à assembler puis cliquez avec le bouton droit de la souris pour afficher le menu 

contextuel, choisissez le sous-menu Stitch pour démarrer l'opération d'assemblage des 

images (on peut également choisir Process>Stitch pour faire la même opération après 

avoir sélectionné les fichiers dans la fenêtre Browse)  

Après avoir sélectionné la commande Stitch, une boîte de dialogue appelée Stitch 
apparaîtra comme indiqué ci-dessous.   
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La boîte de dialogue Stitch et les autres étapes Next> sont identiques à celles de Video 
Stitch.  

L'image finale assemblée ressemblera à ceci :  

Dans l'image assemblée, il y a des zones noires ; celles-ci se produisent lorsqu'il y a des 

translations entre les images de bord dans les deux directions.  

  
L'image assemblée  

13.1 Réduction du bruit  

ToupSky propose 3 méthodes de suppression du bruit, Adaptive Wiener Filter, Bilateral 

Filter, Non Local Means. La vitesse de traitement des 3 méthodes va de rapide à lente, 

et la qualité de la réduction du bruit s'améliore de plus en plus. Chaque méthode est 

décrite en détail ci-dessous :  
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13.1.1 Filtre Wiener Adaptatif  

Le Adaptive Wiener Filter peut préserver plus de détails d'image que ceux du filtre 

médian, du filtre moyen, du filtre Gauss. L'effet est plus remarquable pour le bruit 

additif (comme le bruit gaussien) et le bruit multiplicatif (comme le bruit de Poisson).   

Pour l'algorithme Adaptive Wiener Filter, veuillez trouver les détails dans les littératures 

pertinentes, ici seulement pour illustrer l'amélioration du filtre Wiener adaptatif par 

rapport au filtre Wiener classique.   

Dans le filtre Wiener classique, l'intensité du bruit de l'image nécessite que l'utilisateur 

l'entre manuellement, mais il est difficile d'entrer une valeur précise même pour les 

utilisateurs expérimentés, car la valeur est généralement très petite, comme 0.0036781. 

Par conséquent, dans le développement du Adaptive Wiener Filter, le niveau de bruit est 

automatiquement calculé en fonction de la variance moyenne de l'image.  

Le processus est assez simple, ouvrez une image, choisissez Process>Denoise>Adaptive 

Wiener Filter pour réduire le bruit de l'image.  

13.1.2 Filtre Bilatéral•••  

Le Bilateral Filter est une méthode de filtrage non linéaire qui prend en compte la 

proximité spatiale de l'image, la similitude des valeurs de pixels, les informations 

spatiales de l'image et la similitude des niveaux de gris pour atteindre le but de la 

réduction du bruit en préservant les bords. Le Bilateral Filter a des caractéristiques 

simples, non itératives, locales. Le Bilateral Filter est bon pour préserver les bords de 

l'image par rapport au filtre Wiener ou au filtre Gauss.  

Choisir Process>Denoise>Bilateral Filter••• fera apparaître une boîte de dialogue 

appelée Bilateral Filter comme indiqué ci-dessous :  
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Value domain : la plage de pixels de voisinage en rayon à prendre en compte, plus la 

valeur est grande, plus la vitesse de traitement est lente.  

Space domain : Valeur sigma, plus la valeur est élevée, plus l'effet de réduction du bruit 

est efficace.  

13.1.3 Non Local Means•••  

Le filtre de moyenne locale traditionnel est une méthode de moyenne de pixels autour 

du pixel cible, mais le Non Local Means est une méthode de moyenne pondérée pour 

calculer la moyenne de tous les patches d'image sur la fenêtre de recherche. Le poids 

est déterminé en fonction de la similitude entre le patch cible et les patches de voisinage 

dans la fenêtre de recherche.  

Comparé à d'autres algorithmes de réduction du bruit célèbres, tels que Gauss, filtre 

Wiener, variation totale et débruitage par ondelettes, la méthode Non Local Means peut 

obtenir un meilleur effet.  

Choisir Process>Denoise>Non Local Means••• fera apparaître une boîte de dialogue 

appelée Non Local Means comme indiqué ci-dessous :  

  

Strength : La force de la réduction du bruit, plus la valeur est grande, plus le bruit de 

l'image est éliminé, mais plus de détails sont perdus ;  

Template Window : La taille du bloc de modèle, utilisé pour calculer le poids, la valeur 
par défaut recommandée est 7 ;  

Search Window : La taille de la fenêtre de recherche de patch de modèle, utilisée pour 

calculer la valeur moyenne pondérée parmi les patches d'image. Une grande valeur 

augmentera le temps de traitement. La valeur par défaut recommandée est 21.  
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13.1 Renforcement  

13.1.1 USM•••  

UnSharp Masking (USM) est une technique de renforcement d'image, souvent 

disponible dans les logiciels de traitement d'image numérique. Le "unsharp" du nom 

vient du fait que la technique utilise une image positive floue, ou "non nette", pour 

créer un masque de l'image originale. Le masque non net est ensuite combiné avec 

l'image négative, créant une image moins floue que l'originale.  

Ouvrez une image puis choisissez la commande Process>Sharpen>USM•••, une boîte 

de dialogue apparaîtra comme ci-dessous.  

  

Radius : Affecte la taille des bords à renforcer, donc un rayon plus petit renforce les 

détails de plus petite échelle. Des valeurs de rayon plus élevées peuvent provoquer des 

halos aux bords. En conséquence, les détails fins nécessitent un rayon plus petit. De 

plus, le rayon et le montant interagissent ; en réduire un permet d'en augmenter 

l'autre.  

Threshold : Contrôle le changement de luminosité minimum qui sera renforcé. Ce 

paramètre est important pour éviter que les zones lisses ne deviennent mouchetées. 

Le paramètre de seuil peut être utilisé pour renforcer les bords plus prononcés, tout en 

laissant les bords plus subtils intacts. Les valeurs basses doivent renforcer davantage 

car moins de zones sont exclues.  

Des valeurs de seuil plus élevées excluent les zones de contraste plus faible.  

Amount : est indiqué en pourcentage et contrôle l'ampleur de chaque dépassement 

(combien plus foncés et combien plus clairs deviennent les bords). Cela peut également 

être considéré comme la quantité de contraste ajoutée aux bords. Cela n'affecte pas la 

largeur des bords.  
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a) Image originale ; b) Image renforcée  

13.1.2 Renforcement Laplacien  

Le Laplacian est un exemple de méthode de renforcement de seconde dérivée. Il est 

particulièrement bon pour trouver les détails fins dans une image. Toute caractéristique 

avec une discontinuité nette (comme le bruit, malheureusement) sera renforcée par un 

Laplacian. Ainsi, une application d'un opérateur Laplacian est de restaurer les détails 

fins à une image qui a été lissée pour éliminer le bruit.  

Ouvrez une image puis choisissez Process>Sharpen>Laplacian Sharpen, aucun 

paramètre n'est requis pour cette méthode.  

  
a) Image originale ; b) Image renforcée  

13.1 Coloration  

 13.1.1 Gamma•••     

La commande Process>Color Toning>Gamma••• mesure la luminosité des valeurs des 

tons moyens produites par un appareil (souvent un moniteur). Une valeur gamma plus 

élevée donne une image globalement plus sombre.   
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Preview : Cochez ce bouton pour afficher les effets en temps réel lorsque vous changez 

la position de la barre de défilement. La valeur par défaut est cochée ;  

Gamma : Faire glisser la barre de défilement vers la gauche diminue le niveau, tandis 

que la déplacer vers la droite augmente le niveau. Les valeurs peuvent aller de 0 à 3.0. 

La valeur par défaut est 1.0.  

 13.1.2 Égalisation d'Histogramme•••    Shift+Q  

L'égalisation d'histogramme adaptative (AHE) est une technique de traitement d'image 

informatique utilisée pour améliorer le contraste dans les images. Elle diffère de 

l'égalisation d'histogramme ordinaire (HE) en ce que la méthode adaptative calcule 

plusieurs histogrammes, chacun correspondant à une section distincte de l'image, et 

les utilise pour redistribuer les valeurs de luminosité de l'image. Elle est donc adaptée 

à l'amélioration du contraste local. Cependant, l'AHE a tendance à sur-amplifier le bruit 

dans les régions relativement homogènes d'une image. Une variante de l'égalisation 

d'histogramme adaptative appelée égalisation d'histogramme adaptative à contraste 

limité (CLAHE) prévient cela en limitant l'amplification.  

Veuillez ouvrir une image puis choisir Process>Color Toning>Histogram  

Equalization•••, une boîte de dialogue apparaîtra comme suit.  

  

Strength : La Strength affectera l'effet d'amélioration. Plus la valeur est grande, plus 

l'effet est évident.  
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a) Image originale ; b) Image améliorée  

13.1.3 LCC•••  

L'algorithme de Local Color Correction est calculé en deux étapes :  

Une image de masque est calculée à partir de l'image d'entrée.  

L'image de masque est calculée à partir de la composante d'intensité de l'image couleur, 

définie comme la moyenne des valeurs R, G et B, c'est-à-dire I=(R+G+B)/3. 

L'utilisation des informations d'intensité évite les distorsions de la chrominance. 

L'image de masque est obtenue en inversant puis en floutant la composante d'intensité 

de l'image d'entrée.  

Les images d'entrée et de masque sont combinées pour obtenir le résultat.  

L'opération de combinaison consiste en une fonction de puissance, où l'exposant est 

calculé en utilisant la valeur du masque trouvée précédemment. Si la valeur du masque 

est supérieure à 128, cela se traduira par un exposant inférieur à 1, tandis que si la 

valeur du masque est inférieure à 128, cela se traduira par un exposant supérieur à 1. 

De plus, si la valeur du masque est précisément de 128, l'exposant sera de 1, et cela 

n'aura aucun effet sur l'image d'entrée. L'opération équivaut à une correction gamma 

pixel par pixel.  

Veuillez ouvrir une image puis choisir Process>Color Toning>LCC•••, une boîte de 

dialogue apparaîtra comme suit.  
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Strength˖The strength affectera l'effet d'amélioration. Plus la valeur est grande, plus 

l'effet est évident. Plage : 1~100, la valeur par défaut est 50.  

  

a) Image originale ; b) Image améliorée  

13.1.4 AMSR  

Il y a des problèmes de plage dynamique limitée lorsque des scènes du monde réel 

sont capturées par une caméra numérique et affichées sur des moniteurs. Les 

algorithmes de mappage de tonalité sont appliqués au traitement des images pour 

réduire la plage dynamique d'une image à afficher sur des appareils à faible plage 

dynamique. Le Multi-scale Retinex est l'une des méthodes les plus populaires pour la 

compression de la plage dynamique, la constance des couleurs et le rendu des couleurs. 

Ici, nous améliorons sa performance en adoptant les fonctions de poids adaptatives, 

nommées Adaptive Multi-scale Retinex (AMSR).   

Veuillez ouvrir une image puis choisir Process>Color Toning>AMSR, l'a) Image originale 

; b) Image améliorée  
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 a)  Original image; b) Enhanced image  

13.2 Désentrelacement  

Le désentrelacement est le processus de conversion d'une image ou d'une vidéo 

entrelacée, comme un capteur entrelacé, en une forme non entrelacée.  

13.3 Filtre•••    Shift+I  

Choisissez la commande Process>Filter••• pour appliquer l'un des nombreux filtres de 

ToupSky sur l'image active. Si vous n'êtes pas familier avec le processus et les effets 

de filtrage, certaines discussions sur le filtrage spatial devraient être examinées. 

ToupSky propose un ensemble étendu de filtres de convolution et non convolution 

(morphologiques). Vous pouvez également créer des noyaux de filtre personnalisés et 

les appliquer avec les commandes Filter.  

Choisir la commande Process>Filter••• ouvrira la boîte de dialogue Filter. Chaque 

groupe de filtres a sa propre page de propriétés ou onglet, où le type et la taille du 

Filter peuvent être sélectionnés. Les résultats filtrés sont presque toujours écrits sur 

l'image active. La commande Edit>Undo peut être utilisée pour supprimer les 

opérations de Filter qui ont été appliquées.  

13.3.1 Amélioration de l'Image  
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Low Pass : Cochez ce filtre pour adoucir une image en éliminant les informations haute 

fréquence (cela a pour effet de flouter les bords nets). Le filtre Low Pass remplace le 

pixel central par la valeur moyenne dans son voisinage. Le filtre Low Pass peut 

également être utilisé pour supprimer le bruit.  

High Pass : Cochez ce filtre pour améliorer les informations haute fréquence. Le filtre 

High Pass remplace le pixel central par une valeur convoluée qui augmente 

significativement son contraste par rapport à ses voisins. Le filtre High Pass ne laisse 

que les éléments de haut contraste.  

Gauss : Cochez ce filtre pour adoucir une image en éliminant les informations haute 

fréquence en utilisant une fonction Gauss. Cela a pour effet de flouter les bords nets. 

L'opération du filtre Gauss est similaire à celle du filtre Low Pass, mais elle dégrade 

moins l'image que le filtre Low Pass.  

High Gauss : Cochez ce filtre pour améliorer les détails fins. Cette opération est 

similaire à la technique de masquage flou (voir le filtre Sharpen), mais elle introduit 

moins de bruit dans l'image. Elle utilise un type de noyau de courbe gaussienne. 

Disponible en tailles de noyau 7x7 et 9x9.  

Equaliza-tion : Ce filtre est utilisé pour améliorer le contraste basé sur l'histogramme du 

voisinage local (voir Option ci-dessous).  

Sharpness : Cochez ce filtre pour améliorer les détails fins, ou refocaliser une image 

floue. Le filtre de netteté renforce l'image en utilisant la technique de masquage flou.  

Median : Cochez ce filtre pour supprimer le bruit impulsionnel d'une image. Le filtre 

Median remplace le pixel central par la valeur Median dans son voisinage. Il floutera 

également l'image.  

Rank : Cochez ce filtre pour supprimer le bruit impulsionnel d'une image. Les pixels 

dans le noyau sont classés par ordre d'intensité, et le pixel de cette gamme au 

pourcentage de rang est choisi pour la comparaison. Par exemple, dans un noyau 

5x5, il y a 25 pixels. Un pourcentage de rang de 95% choisirait le deuxième pixel le 

plus lumineux pour la comparaison. Si la différence entre le pixel sélectionné et le 

pixel central est supérieure à la valeur seuil, le filtre Rank remplace la valeur du pixel 

central par la valeur du pixel sélectionné.  
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Option :1. Si l'un des filtres Enhancement est coché, les options suivantes seront 

affichées :  

3 x 3 : Cocher le noyau 3 x 3 produira un effet de filtrage plus subtil.  

5 x 5 : Cocher le noyau 5 x 5 produira un effet de filtrage modéré.  

7 x 7 : Vérifiez 7 x 7 noyau produira un effet de filtrage plus extrême.  

Passes: Définissez le nombre de fois que le filtre sera appliqué à l'image. 

Lorsqu'un filtre est appliqué plusieurs fois, son effet est amplifié par chaque 

passage. Une image qui a été adoucie par un passage du filtre Low Pass sera 

adoucie davantage par un second passage.  

Strength: Entrez une valeur appliquée de 1 à 10 qui reflète l'intensité de l'effet de 

filtrage sur l'image.  

Une valeur de 10 spécifie la pleine intensité (100%) du résultat filtré appliqué à 
chaque pixel. Les valeurs inférieures à 10 réduisent le poids total du filtre.  

Une valeur de 1 indique que seulement 10% de la différence entre la valeur du 

pixel filtré et la valeur du pixel d'origine doit être appliquée, une valeur de 2 

indique que 20% de la différence doit être appliquée, et ainsi de suite.  

Rank : Cette valeur spécifie quel pixel dans le tableau trié sera utilisé pour 

remplacer le pixel central. Les pixels dans le tableau seront triés par ordre 

croissant. Les pixels sont indexés de 0 à Kernel Size x Kernel Size-1. Dans l'index 

de pixel, 0 correspond à la valeur de pixel la plus basse.  

Le Rank sera spécifié en termes de pourcentage des index (Kernel Size x Kernel 

Size-1). Un rang de 50% signifie le milieu du tableau. 0% de rang signifie l'index 

le plus bas (valeur de gris la plus basse), et 100% de rang signifie l'index le plus 

élevé (valeur de gris la plus élevée).  

Option: 2. Si le filtre Equalization est coché, les options concerneront l'égalisation de 

l'histogramme. Local Histogram Equalization modifie le contraste d'une image en 

fonction des valeurs de pixel dans une petite fenêtre entourant chaque pixel.  

Window: Les statistiques des pixels d'image (min, max, histogramme, moyenne, 

écart type, etc.) seront calculées sur une petite Window  de l'image. Ces mesures 

sont ensuite utilisées pour dériver le contraste local pour cette zone de l'image. 



Process  

97  

En bref, une zone de Window x Window autour de chaque pixel est tout ce qui est 

pris en compte lors de la modification des intensités dans l'image. Une Window 

plus grande produit des résultats plus lisses, tandis qu'une Window plus petite 

suit de plus près les petits détails.  

Best Fit: Choisissez le bouton Best Fit pour optimiser les valeurs pour l'image 

particulière. Les résultats sont obtenus en étirant l'histogramme local pour 

maximiser le contraste entre les pixels les plus clairs et les plus sombres dans la 

région de la fenêtre locale.  

Linear: Cette option distribue l'histogramme de manière linéaire sur l'échelle 

d'intensité. Cette fonction produit une image à contraste élevé avec la plage 

dynamique la plus élevée possible.  

Logarithmic: Cette option concentre l'histogramme à l'extrémité inférieure de 

l'échelle. Cette fonction produit une image à contraste élevé avec peu d'image 

dynamique. Elle aura tendance à assombrir globalement l'image. Elle est utile 

pour augmenter le contraste dans une image très claire.  

Exponen-tial: Cette option concentre l'histogramme à l'extrémité supérieure de 

l'échelle. Cette fonction produit une image à contraste élevé avec peu d'image 

dynamique. Elle aura tendance à éclaircir globalement l'image. Elle est utile pour 

augmenter le contraste dans une image très sombre.  

13.3.2 Renforcement des bords  
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Sobel : Cochez ce filtre pour renforcer uniquement les principaux bords d'une image. 

Le Sobel applique une formule mathématique à un voisinage de 3x3 pour localiser et 

mettre en évidence ses bords.  

Roberts: Cochez ce filtre pour renforcer les bords fins d'une image. Le filtre Roberts 

n'est pas un filtre de convolution. Il applique une formule mathématique sur un 

voisinage de 4 x 4 pour produire son effet. Le pixel en haut à gauche du voisinage est 

celui qui est remplacé.  

Sculpt: Cochez ce filtre pour appliquer un effet sculpté sur l'image.  

Horizontal: Cochez ce filtre pour détecter et souligner les bords horizontaux.  

Vertical: Cochez ce filtre pour détecter et souligner les bords verticaux.  

Options : 1. Si l'un des filtres Edge a été coché, les options concerneront la taille du 

noyau et l'intensité du filtrage. Les options suivantes seront affichées :  

3 x 3 : Cochez les noyaux 3x3 pour produire un effet de filtrage plus subtil.  

5 x 5 : Cochez les noyaux 5x5 pour produire un effet de filtrage modéré.  

7 x 7 : Cochez les noyaux 7x7 pour produire un effet de filtrage plus extrême.  

Passes: Entrez le nombre de fois que le filtre sera appliqué à l'image. Lorsqu'un 

filtre est appliqué plusieurs fois, son effet est amplifié par chaque passage. Une 

image qui a été adoucie par un passage du Image Enhancement Filter, sera 

adoucie davantage par un second passage.   

Strength: Entrez une valeur de 1 à 10 qui reflète l'intensité de l'effet de filtrage à 

appliquer à l'image. Une valeur de 10 spécifie que la pleine intensité (100%) du 

résultat filtré sera appliquée à chaque pixel. Les valeurs inférieures à 10 réduisent 

le poids total du filtre - une valeur de 1 indique que seulement 10% de la 

différence entre la valeur du pixel filtré et la valeur du pixel d'origine doit être 

appliquée, une valeur de 2 indique que 20% de la différence doit être appliquée, 

et ainsi de suite.  

Option 2. Si Sobel ou Roberts est coché, aucune option n'est disponible.  
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13.3.3 Morphologique  

  
Erode: Cochez ce filtre morphologique si vous souhaitez modifier la taille des objets 

dans l'image. Le filtre Erode érode les bords des objets lumineux et agrandit les bords 

des objets sombres.  

Dilate: Cochez ce filtre morphologique si vous souhaitez modifier la taille des objets dans 

l'image. Le filtre Dilate dilate les objets lumineux et érode les objets sombres.   

Open: Cochez ce filtre morphologique si vous souhaitez modifier la forme des objets 

dans l'image. En supposant que l'image contient des objets lumineux sur un fond 

sombre, le filtre Open lissera les contours des objets, séparera les objets étroitement 

connectés et supprimera les petits trous sombres.   

Close: Cochez ce filtre morphologique si vous souhaitez modifier la forme des objets 

dans l'image. En supposant que l'image contient des objets lumineux sur un fond 

sombre ; le filtre Close remplira les espaces et agrandira les saillies pour connecter 

les objets qui sont proches les uns des autres.   

Tophat: Cochez ce filtre pour détecter et souligner les points, ou grains, qui sont plus 

lumineux que le fond. Il y a 3 tailles de noyau pour ce traitement. Cliquez sur le 

bouton radio pour changer la taille du noyau à la valeur qui correspond le mieux à la 

taille des grains à détecter.  

Well: Cochez ce filtre pour détecter et souligner les points, ou grains, qui sont plus 

sombres que le fond. Il y a 3 tailles de noyau pour ce traitement. Cliquez sur le 

bouton radio pour changer la taille du noyau à la valeur qui correspond le mieux à la 

taille des grains à détecter.  
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Gradient: Cochez ce filtre pour renforcer les bords d'une image.  

Watershed: Cochez ce filtre pour séparer les objets qui se touchent. Le filtre 

Watershed érode les objets jusqu'à ce qu'ils disparaissent, puis les dilate à nouveau, 

mais ne leur permettra pas de se toucher. Le filtre Watershed ne fonctionnera pas sur 

les images en vraies couleurs. Si vous souhaitez séparer les objets dans une image en 

vraies couleurs, vous devez d'abord la convertir en Gray Scale (voir Process Frame: 

Image>Gray Scale).  

Thinning: Cochez ce filtre pour réduire une image à son squelette. En choisissant ce 

filtre, vous devez définir le seuil qui détermine si un pixel fait partie du sujet ou du 

fond (voir Options ci-dessous). Le filtre Thinning ne fonctionnera pas sur les images 

en vraies couleurs. Si vous souhaitez amincir une image en True Color, vous devez 

d'abord la convertir en Gray Scale.   

Distance: Le filtre de distance est utilisé pour montrer les distances des pixels à 

l'intérieur des blobs jusqu'aux limites extérieures de ces blobs. Après avoir appliqué le 

filtre de distance, le fond sera noir (c'est-à-dire des pixels avec une valeur de 0). 

Seule la zone à l'intérieur des blobs aura des valeurs non nulles (sera blanche). Les 

valeurs de chaque pixel à l'intérieur du blob seront un compte de la distance la plus 

courte entre ce pixel et le bord du blob. Ainsi, tous les pixels le long du bord du blob 

auront une valeur de 1 (puisqu'ils sont à un pixel du bord du blob); les pixels qui sont 

à une distance de 2 du bord auront la valeur 2, et ainsi de suite. Cela crée une carte 

de distance de l'image. Le filtre Distance ne fonctionnera pas sur les images en True 

Color. Si vous souhaitez utiliser le filtre Distance avec une image en True Color, vous 

devez d'abord la convertir en Gray Scale.  

Options 1. Si les filtres Erode, Dilate, Open, ou Close sont cochés, les options 

concerneront la taille et la forme du noyau. Les options suivantes seront présentées :  

2 x 2 Square: Cochez pour utiliser les configurations de noyau carrées 2x2.  

3 x 1 Row : Cochez pour utiliser la configuration de noyau de rangée 3x1.   

1 x 3 Column : Cochez pour utiliser la configuration de noyau de colonne 1x3.  

3 x 3 Cross : Cochez pour utiliser la configuration de noyau en croix 3x3.  

5 x 5 Circle : Cochez pour utiliser les configurations de noyau circulaires 5x5.  
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7 x 7 Circle : Cochez pour utiliser les configurations de noyau circulaires 7x7. Ceci 

est un filtre à deux passes, réalisé en utilisant un cercle de 5 x 5 suivi d'une croix 

de 3x3.   

11 x 11 Circle : Cochez pour utiliser les configurations de noyau circulaires 11 x 

11. Ceci est un filtre à trois passes, réalisé en utilisant un cercle de 5 x 5 suivi 

d'un autre cercle de 5 x 5, suivi d'une croix de 3 x 3.   

Passes: Définissez le nombre de fois itérer le filtre.  

Remarque : Les noyaux circulaires sont particulièrement efficaces sur les objets ronds 

(cellules, grains, etc.) car leur configuration circulaire préserve mieux la forme 

circulaire des objets que les configurations carrées.  

Option 2. Si les filtres Tophat, Well, ou Gradient sont sélectionnés, les options 

concerneront la taille et la forme du noyau. Les options suivantes seront présentées :  

3 x 3 : Cochez pour utiliser les configurations de noyau 

carrées 3x3. 5 x 5 : Cochez pour utiliser les configurations 

de noyau carrées 5x5.  

7 x 7 : Cochez pour utiliser les configurations de noyau carrées 7x7.  

Option 3. Si le filtre Watershed, Thinning, ou Distance est coché, les options 

concerneront le seuil. L'option suivante sera présentée :  

Threshold : Entrez une valeur en pourcentage de 1 à 100 qui spécifie la valeur 

d'intensité pour binariser l'image. Par exemple, un seuil de 50% sur une image en 

Gray Scale fixerait toutes les valeurs ≤127 à 0 (noir) et toutes les valeurs ≥128 à 

la valeur maximale pour cette classe d'image (blanc).  

13.3.4 Noyau  

La page Kernel permet de modifier les fichiers noyau pour les filtres morphologiques et 
de convolution.  
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Remarque : Les fichiers noyau HiPass, LowPass, Laplacian et Unsharp  sont utilisés par 

les options HiPass, LowPass, Laplacian, et Sharpen répertoriées dans la fenêtre de 

dialogue de la page Image Enhancement Filters (c'est-à-dire qu'il n'y a pas de 

différence entre sélectionner l'un de ces fichiers noyau et sélectionner son bouton 

Option dans la fenêtre Filter -- les deux méthodes font finalement la même chose). 

Parce que ces fichiers noyau sont essentiels au fonctionnement de ces options de 

filtrage, ils ne doivent pas être supprimés ou renommés.  

Filter type: Cochez pour modifier le noyau pour un type de filtre sélectionné Filter type, 

soit les filtres de Convolution ou de Morphological.  

Edit•••: Invoquez la boîte de dialogue Edit Kernel pour modifier le noyau de filtre 
sélectionné.  

Name•••: Cette boîte combo contient le nom du fichier noyau sélectionné. Si vous 

souhaitez enregistrer le fichier noyau modifié dans le même fichier, laissez-le tel 

quel. Si vous souhaitez enregistrer le fichier dans un nouvel emplacement, entrez 

le nouveau nom de fichier ici.  

Kernel Size: Cliquez sur les boutons de rotation ou entrez le nombre pour changer 

la taille du noyau. Les deux directions peuvent tenir compte d'un à neuf pixels. 

Lorsque vous modifiez la Kernel Size, la forme de la représentation du noyau 

change en conséquence. Au centre de la boîte de dialogue, il y a des cases 

blanches contenant des coefficients qui seront multipliés par chaque pixel pris en 

compte par le filtre noyau. Vous pouvez changer n'importe quel coefficient en 

cliquant dessus et en l'ajustant comme désiré.  
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Fill: Cliquez sur ce bouton pour remplir chaque élément du noyau avec une valeur 
particulière.  

La boîte de dialogue Fill kernel apparaît. Vous pouvez entrer une valeur entre 0 et 
10. Utiliser  

le bouton Fill est utile pour définir tous les coefficients à la même valeur. Vous 

pouvez ensuite changer les coefficients qui nécessitent une valeur différente.  

Offset: Le pixel dont la valeur est modifiée est généralement le pixel central. 

Cependant, vous pouvez désigner n'importe quel pixel. ToupSky signale le pixel à 

changer en mettant une boîte autour de lui. Choisissez les boutons de rotation X 

et Y Offset pour appliquer  

New•••: Cliquez pour créer un nouveau noyau de filtre. La boîte de dialogue Edit 

Kernel apparaîtra. Les fonctions de la boîte de dialogue sont les mêmes que la boîte 

de dialogue pour Edit•••  décrite ci-dessus), à l'exception que le nom de fichier pour 

le nouveau fichier noyau doit être fourni.  

Delete: Cliquez pour supprimer le fichier noyau de filtre sélectionné.  

Options: Les choix dans ce groupe varieront en fonction du type de filtre sélectionné.  

13.4 Empilement d'images•••     

La méthode d'empilement d'images est une forme d'imagerie par tavelures 

couramment utilisée pour obtenir des images de haute qualité à partir de plusieurs 

expositions courtes avec des décalages d'image variés. Elle est utilisée en astronomie 

depuis plusieurs décennies et est à la base de la fonctionnalité de stabilisation d'image 

sur certaines caméras. La méthode implique le calcul des décalages différentiels des 

images. Cela est facilement accompli dans les images astronomiques car elles peuvent 

être alignées avec les étoiles. Une fois les images alignées, elles sont moyennées 

ensemble. C'est un principe de base de la statistique que la variation dans un 

échantillon peut être réduite en moyennant ensemble les valeurs individuelles. En fait, 

en utilisant une moyenne, le rapport signal/bruit devrait être augmenté d'un facteur 

égal à la racine carrée du nombre d'images.  

L'empilement d'images peut également être utilisé pour l'imagerie microscopique 

biologique et l'imagerie microscopique fluorescente pour augmenter le rapport 
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signal/bruit de l'image et les plages dynamiques; c'est pourquoi nous introduisons 

l'empilement d'images dans ToupSky.  

ToupSky Image Stacking a introduit des techniques avancées de correspondance 

d'images pour les images tournées, décalées et mises à l'échelle. L'utilisateur peut 

enregistrer une courte vidéo pour obtenir une image empilée de haute qualité 

facilement sans se soucier de la rotation, du décalage et de la mise à l'échelle de l'image 

entre une série d'images dans la vidéo. Les étapes de l'empilement d'images sont 

décrites ci-dessous :  

1ˊ Choisissez le menu Processing>Image Stacking•••, une boîte de dialogue Windows 

Open apparaîtra comme illustré ci-dessous;  

  

2ˊ Choisissez le bon fichier vidéo enregistré précédemment dans la boîte de dialogue 

Open, ici nous pouvons ouvrir “test.avi” pour la démonstration, cliquez sur Open 

pour ouvrir le fichier avi;  

3ˊ Ensuite, une boîte de dialogue Image Stacking apparaîtra pour montrer la 

progression de l'empilement de chaque image.   

  

4ˊ Si Cancel est pressé, l'empilement d'images Image Stacking sera annulé. Après la 

fin de l'empilement, une image empilée sera affichée dans une nouvelle fenêtre 

pour une application ultérieure. L'image finale est illustrée ci-dessous. On peut 
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constater que le rapport signal/bruit de l'image empilée est grandement amélioré. 

L'image empilée a quelques bords noirs, cela est dû au fait que les images dans la 

vidéo sont déplacées et que dans le processus d'empilement, ToupSky ajoute 0 à 

la zone de l'image qui n'a pas de pixel correspondant dans l'image de référence 

(nous choisissons la première image dans le fichier vidéo comme image de 

référence).  

  
Remarque : a. ToupSky prend en charge 

wmvˈasfˈaviˈmp4ˈm4vˈ3gpˈ3g2ˈ3gp2ˈ3gppˈmovˈ mkvˈflvˈrmˈrmvb pour 

l'opération Image Stacking ; b) Dans le processus d'empilement d'images Image 

Stacking, ToupSky prend la première image comme image de référence, cela signifie 

que la première image est très importante et doit être assurée comme la scène de 

l'image correcte et les images suivantes doivent avoir une plus grande région de 

chevauchement avec la première image.  

13.1 Range•••    Shift+R  

La commande Process>Range••• permet de définir les niveaux d'intensité de l'image 

pour augmenter le contraste et améliorer l'affichage dans des situations de faible 

luminosité. Choisissez la commande Range pour ouvrir la boîte de dialogue Range.  

Deux vertical markers montrent les limites upper et lower des niveaux d'intensité. Ces 

marqueurs peuvent être déplacés avec la souris par glisser-déposer. Pour une image 

en couleur, l'histogramme reflétera les valeurs red, green, et blue avec des lignes de 

couleurs correspondantes.  
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Deux contrôles Edit indiquent les valeurs des niveaux d'intensité. Choisissez les boutons 

de rotation pour augmenter ou diminuer ces valeurs. Toutes les valeurs entre 0 et la 

limite inférieure seront noires et toutes les valeurs entre la limite supérieure et 

l'extrémité supérieure de l'échelle seront blanches. Ces deux valeurs de contrôle 

d'édition correspondant aux deux vertical markers montrent les limites upper et lower 

des niveaux d'intensité. Les valeurs par défaut sont o et 255 respectivement.  

Reset: Le bouton Reset permet de Reset les niveaux de noir et de blanc aux extrémités 

haute et basse de la plage dynamique Range.  

Best Fit: Le bouton Best Fit définit automatiquement les niveaux d'intensité sur le 

Best Fit. Best Fit indique à ToupSky d'optimiser les valeurs de luminosité et de 

contraste pour l'image particulière.  

Invert: Le bouton Invert inverse la couleur de l'image.  

Update: Update actualisera l'affichage Range avec les informations d'image les plus 
récentes.  

13.1 Binary•••    Shift+B  

Binary est un type de traitement de niveau de gris. Si le gris du pixel est supérieur au 

seuil donné, la couleur du pixel sera changée en blanc. Sinon, la couleur du pixel sera 

changée en noir. Bien que le processus puisse perdre certaines informations, c'est une 

étape importante d'autres processus.  

  

La courbe sur la boîte de dialogue Binary montre la distribution des gris de l'image.  

La Line dans la boîte de dialogue indique la valeur seuil. Faites glisser la ligne pour 

changer le seuil, ou modifiez la valeur dans la boîte Line edit (dans le coin supérieur 

gauche de la boîte de dialogue) pour déplacer la Line.  

La boîte Line edit montre la valeur de position actuelle de la Line ; modifier la valeur 

déplacera la Line en même temps ;  



Process  

107  

Cliquez sur le bouton "Best Fit" pour appliquer le processus de seuil automatique à 

l'image. Il utilise un seuil automatique pour rendre l'image Binary. 

13.1 Pseudo Color•••  

Remarque : L'image doit être en Gray Scale.   

Choisissez la commande Pseudo Color pour "coloriser" l'image monochromatique 

active. Cela est utilisé pour mettre en évidence certaines caractéristiques dans une 

image en niveaux de gris telles que l'affichage de toutes les densités au-dessus d'un 

certain point en rouge, ou, si le dispositif d'imagerie a enregistré des informations 

thermiques, toutes les températures en dessous d'un certain point peuvent être 

révélées en bleu.  

  
Lors de l'application de Pseudo Color à une image monochromatique, une palette 

spéciale doit être construite avec laquelle l'image monochromatique est affichée. 

L'application de Pseudo Color à une image ne modifie pas les valeurs des pixels dans 

l'image bitmap (elle ne convertit pas l'image en vraies couleurs ou en palette). Elle 

associe simplement une palette Pseudo Color à l'image qui interprète les valeurs de 

niveaux de gris de l'image comme des couleurs.   

Les images en pseudo-couleur sont très similaires en structure aux images de classe 

palette, mais elles diffèrent en quelques points importants. Tout d'abord, les valeurs 

des pixels dans une image en Pseudo Color représentent en réalité des informations 

d'intensité en tons continus, alors que les pixels d'une image en palette ne portent 

aucune signification d'intensité. Deuxièmement, une image en palette inclut une table 

de palette qui fait en réalité partie du fichier image.   

Les couleurs utilisées pour mapper les valeurs de gris peuvent être 
sélectionnées. Les boutons à  

chaque extrémité des bandes de couleurs (  )     ou  
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apparaître la boîte de dialogue couleur séparément, ce qui permet de 

sélectionner les couleurs de début et de fin de la plage.  

13.1 Surface Plot•••  

L'outil Process>Surface Plot••• (ou tracé 3D) crée une représentation 3D de l'intensité 

d'une image. En choisissant la commande Surface Plot, gardez à l'esprit que X=largeur 

de l'image et Y=hauteur de l'image, et Z=valeur de gris du pixel.  

Dans la fenêtre de point de vue, l'elevation et la rotation de l'image peuvent être 
ajustées en faisant glisser la souris sur l'image.  

  

Position Solid: Le contrôle d'édition de gauche indique la position relative de l'ensemble 

de l'image dans la fenêtre de point de vue, dont la valeur par défaut est de 0,5. Le 

contrôle d'édition de droite indique la hauteur relative de l'affichage de l'échelle Z, dont 

la valeur par défaut est de 1.  

Reset : Réinitialisez les deux contrôles d'édition de Position Solid à leurs valeurs par 
défaut.  

Image Background Color: Choisissez cette commande pour afficher une boîte de 

dialogue couleur où vous pouvez ajuster la couleur de fond de la fenêtre de point de 

vue.  

Capture: Capture l'image active dans la fenêtre de point de vue en tant que nouvelle 
image.  
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Color Table: Sélectionnez les couleurs pour mapper les valeurs de gris trouvées dans 

le tracé de surface. Le bouton à chaque extrémité de la Color Table fait apparaître la 

boîte de dialogue couleur, ce qui permet de sélectionner les couleurs de début et de fin 

de la plage. (Se référer à Pseudo Color pour plus d'informations)
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14 Options  

14.1 Preferences•••     

Il y a 7 pages pour la boîte de dialogue Preference. Elles sont Record, Batch Record, 

Auto Capture, File, Grids, Video et Misc.  

14.1.1 Record Page  

La page Record peut être utilisée pour la pré-configuration de la commande 

Capture>Start Record sans avoir besoin de spécifier ultérieurement le répertoire de 

fichier, le nom de fichier et le format de fichier.  

Tout cela est spécifié dans la page de propriété Options>Preferences•••>Record .  

  
Directory : Entrez le nom du lecteur et du répertoire où la nouvelle image sera 
sauvegardée.  

Vous pouvez soit taper les informations du chemin, soit utiliser le bouton Browse  
pour le localiser depuis une boîte de dialogue Browse Folder standard ;  

Name Format : L'année year, le mois month, la date date, l'heure hour, la minute minute 

et la seconde second ou nnnn(sequence) peuvent être utilisés comme partie du nom de 

fichier. Si plusieurs fichiers sont sauvegardés en une seconde, un suffixe (xx) est ajouté 

à la fin de Name Format pour éviter les conflits de nom. Pour le nnnn(sequence) Name 

Format, aucun suffixe n'est nécessaire ;  

File Prefix : Entrez un préfixe de nom de fichier pour la commande Capture>Start 

Record ou Capture>Batch Record lors de la génération de noms de fichiers pour la 

vidéo (Capture>Start Record) ou une série de vidéos (Capture>Batch Record). Ce 
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préfixe sera combiné avec le Name Format pour former un nom de fichier final selon 

le paradigme de nommage ;  

File Type : Dans cette boîte combo, sélectionnez le format dans lequel vous souhaitez 
que l'image soit enregistrée (cela peut être SER ou AVI) ;  

Sample : Le nom de fichier final est affiché à droite de l'étiquette Sample pour référence 
;  

Show the rename file dialog: Le nom de fichier peut être renommé en fonction de la 

configuration de cet élément. Lorsque cet élément est coché, une boîte de dialogue 

Rename apparaîtra après avoir choisi la commande  capture>Start Record ou cliqué sur 

le bouton  sur la barre d'outils. Le nouveau nom peut être spécifié ici à nouveau 

selon les besoins ;  

  

Limit>Time Limit(Secord(s)): Le temps total pour l'enregistrement ; la valeur par défaut 

est de 60 (1~3600s) ;  

Limit>Frame Limit: Le nombre de trames à enregistrer ; la valeur par défaut est de 

1000 (1~ 1000000) ;  

Lorsque les deux sont cochés, l'enregistrement vidéo sera arrêté après qu'une des 

limites soit atteinte.  

14.1.2 Batch Record Page  

La page Batch Record est utilisée pour la pré-configuration de la commande 

Capture>Batch Record. Choisir la page de propriété Options>Preferences•••>Batch 

Record invoquera une boîte de dialogue comme illustré ci-dessous :  
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Number: Le nombre de fichiers à enregistrer (2~10000, par défaut 10).  

Time interval (Second(s): Combien de temps il faudra pour enregistrer le fichier vidéo 

suivant (0~36000, par défaut 10) ;  

L'autre paramètre d'enregistrement peut être défini dans la page de propriété 

Options>Preferences•••>Record . Veuillez le vérifier pour plus de détails.  

14.1.3 Auto Capture  

La page Auto Capture est utilisée pour la configuration de la commande Capture>Auto 
Capture.  

Cela peut être fait dans la page de propriétés Options>Preferences•••>Auto Capture :  

  
Directory : Entrez le nom du lecteur et du répertoire où la nouvelle image sera 
sauvegardée.  
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Vous pouvez soit taper les informations du chemin, soit utiliser le bouton Browse  

pour le localiser depuis une boîte de dialogue Browse Folder standard ;  

Name Format : Les year, month, date, hour, minute et second ou nnnn(sequence) sont 

utilisés comme partie du nom de fichier. Si plusieurs fichiers sont sauvegardés en une 

seconde, un suffixe (xx) est ajouté à la fin de Name Format pour éviter les conflits de 

nom. Pour le nnnn(sequence) Name Format, aucun suffixe n'est nécessaire.  

File Prefix : Entrez un préfixe de nom de fichier pour Auto Capture lors de la génération 

de noms de fichiers pour une série d'images. Ce préfixe sera combiné avec Name Format 

pour former un nom de fichier final selon le paradigme de nommage.  

File Type : Dans cette combobox, sélectionnez le format dans lequel vous souhaitez 
enregistrer l'image (peut être BMP, JPG, PNG, TIF, FIT) ;  

Sample : Le nom de fichier final est affiché à droite de l'étiquette Sample pour référence 
;  

Capture every frame : Cocher cet élément capturera chaque image de la séquence vidéo 
;  

Time slot(second): Capturez une image selon l'intervalle de temps (0-100S, la valeur 

par défaut est 6) ;  

Total Images : Cochez Total Images activera sa zone de saisie. Vous pouvez entrer le 

Total Images (1-9999) à capturer. ToupSky arrêtera automatiquement le processus 

Auto Capture lorsque le nombre total d'images Total Images sera atteint ;  

Si Total Images n'est pas coché, ToupSky capturera les images en continu jusqu'à ce 

que l'utilisateur choisisse à nouveau la commande Capture>Stop Capture pour arrêter 

le processus Auto Capture.  

Après que le Auto Capture est commencé, le menu Capture>Auto Capture sera 

changé en menu Capture>Stop Capture. Choisir cette commande arrêtera le 

processus Auto Capture.  

Il existe une variété de formats d'image disponibles (ils sont bmp, jpg, png, tif ou fit) 

pour enregistrer l'image capturée. Par exemple, en choisissant le format jpg, les options 

de sauvegarde peuvent être définies dans la page de propriétés 
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Options>Preferences•••>File. Si le format a des options, le bouton Config•••  sera 

activé.   

  
Cliquer sur le bouton Config••• fera apparaître une boîte de dialogue comme ci-dessous. 

Différents formats ont différentes options.  

Après que tous les paramètres sont définis. Cliquez sur OK pour fermer la boîte de 

dialogue et les paramètres peuvent être utilisés pour la commande Auto Capture sans 

configuration supplémentaire.  

  

Voir la page Options>Preference•••>File page pour plus de détails.  

14.1.4 File Page  

On peut vérifier une Extension de fichier pour le Format de fichier spécifié et son Abbr. 

(abréviation), pour déterminer s'il sera affiché dans la fenêtre Browse ou non (Le Format 

coché peut être affiché dans la fenêtre Browse).  
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Extension: Utilisé pour identifier l'extension de fichier ;  

Format : Nom complet en anglais des formats de fichier ;  

Abbr.: Abréviation du Format de fichier ;  

Browse: Cochez/décochez pour déterminer si le format de fichier peut être affiché dans 

la fenêtre Browse ;  

Config…: Pour configurer l'option Save As pour les formats JPEG, Portable Network 

Graphics, Tag Image File Format, CompuServ, JPEG 2000 Standard, JPEG Codestream, 

GIF. Pour plus de détails, veuillez vous référer à l'explication du bouton Option dans 

File>Save As dans Sec.6.4  

14.1.5 Grids Page  

Choisir la commande View>Grid>Setting•••, ou choisir la commande Options> 

Preference>••• et cliquer sur la page Grids pour réaliser la même fonction.  

Choisir la commande Preference>••• et cliquer sur la page Grids peut définir le Grid 

Style, Line Style, et Line Color pour la grille Grid superposée sur la fenêtre vidéo et 

image peut également être définie.  
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Grid Style: Le Grid Style peut être No Grid, Auto Grid ou Manual Grid. La valeur par 
défaut est No Grid ;  

Grid Line Style: Le Line Style pour la grille peut être Solid, Dash, Dot ou DashDot, etc. 

La valeur par défaut est Solid ;  

Grid Line Color: La couleur de la ligne de la grille. La valeur par défaut est Rouge 
(255,0,0).  

14.1.6 Video Page  

Choisissez la boîte de dialogue Options>Preference et cliquez sur  Video pour afficher la 

page Video. La page Vidéo est utilisée pour définir la Date Time et le Clarity Factor  pour 

les superposer sur la fenêtre vidéo.  

  
La Position, Background, Font Size, Font Weight  de la Date Time, et le Clarity Factor 

peuvent être définis ensemble. Leurs Colors  peuvent être définis séparément.  
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Cliquer sur le bouton OK et la Date Time, et le Clarity Factor  seront superposés sur la 

fenêtre Video.  

Le Clarity Factor peut indiquer si l'échantillon est dans un bon état de mise au point ou 

non. Plus le Clarity Factor est grand, meilleur est l'échantillon mis au point.  

14.1.7 Misc Page  

La page Misc est principalement utilisée pour le contrôle de l'interface utilisateur de 
ToupSky. Il comprend principalement :  

1. Afficher les fenêtres de démarrage ;  

2. Empêcher l'écran de veille lors de la prévisualisation/enregistrement vidéo  

3.Unités de température ;  

4. Barres latérales ;  

5. Style de l'interface utilisateur ;  

6. Langue ;  

7. Activer le traitement d'image accéléré par GPU ; 8. Confidentialité ; paramètres, etc. 

Ils sont tous présentés ci-dessous.  

  



Options  

118  
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15 Fenêtre  
15.1 Fermer tout  

Choisir la commande Close All pour fermer toutes les images ouvertes ou capturées 

dans le cadre ToupSky. Si vous avez apporté des modifications aux images ou si vous 

avez capturé des images de la caméra, choisir la commande Close All vous permettra 

de terminer rapidement les opérations de sauvegarde.  

  
Si les fenêtres d'image ci-dessus existent, choisir la commande Window>Close All fera 

apparaître une boîte de dialogue Save Files comme ci-dessous :  

  

1. Cliquer sur Yes dans la boîte de dialogue Save Files fermera directement les fenêtres 

Video, Browse, Image qui ne sont pas modifiées sans rien demander. S'il y a une 

nouvelle fenêtre Image, ToupSky fera apparaître une boîte de dialogue Save As pour 

inviter l'utilisateur à entrer le File name pour enregistrer le fichier.  
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Si Save ou Cancel est cliqué dans la boîte de dialogue Save As, ToupSky retournera à 

la boîte de dialogue Save Files  pour continuer l'opération de fermeture du fichier 

suivant ;  

2. Cliquer sur No dans la boîte de dialogue Save Files fermera la fenêtre d'image 

actuelle sans opération de sauvegarde et retournera à la boîte de dialogue Save Files  

pour continuer l'opération suivante ;  

3. Cliquer sur Cancel annulera la boîte de dialogue Save Files  sans rien faire ;  

4. Cliquer sur Yes to All dans la boîte de dialogue Save Files fera toujours apparaître 

une boîte de dialogue Save As pour vous permettre d'entrer le File name pour 

enregistrer les fichiers un par un jusqu'à ce que tous les fichiers soient enregistrés ;  

5. Cliquer sur No to All dans la boîte de dialogue Save Files fermera toutes les fenêtres 

d'image sans les enregistrer ;  

6. Cliquer sur Batch Save dans la boîte de dialogue Save Files transférera le processus 

de sauvegarde à la commande File>Batch Save•••. Veuillez consulter le menu 

File>Batch Save••• pour plus de détails ;  

Remarque : Si vous avez beaucoup d'images ouvertes et que vous avez apporté des 

modifications, et que vous souhaitez les fermer rapidement sans rien enregistrer, vous 

pouvez utiliser cette commande et choisir l'étape 5. Toutes les images seront fermées 

instantanément, aucun avertissement ne sera donné.  

15.2 Réinitialiser la disposition des fenêtres  

Choisir Window>Reset Window Layout réinitialisera la disposition des fenêtres de 

ToupSky à l'originale. La réinitialisation sera effective après le redémarrage.  
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15.3 Fenêtres•••  

Choisir la commande Window>Windows••• ouvrira une boîte de dialogue qui vous 

permettra de gérer les fenêtres actuellement ouvertes.  

La boîte de dialogue vous permet de gérer de longues listes de fenêtres ouvertes en les 

assignant à des groupes. Supposons que vous ayez 10 fenêtres ouvertes, mais que 

vous souhaitiez en fermer 4 disséminées dans la liste.  

  
1. Choisissez la commande Window>Windows••• ;  

2. Sélectionnez les fenêtres que vous souhaitez fermer. Maintenez la touche Ctrl ou 

Shift enfoncée pour en sélectionner plus d'une à la fois. Ici, 4 éléments sont 

sélectionnés ;  

  
3. Cliquez sur le bouton Close Window(s), ces 4 fenêtres sélectionnées seront fermées, 

laissant les autres fichiers ou captures disponibles pour édition ;  

4. L'utilisateur peut utiliser cette commande pour basculer vers la fenêtre cochée sur 

une liste en appuyant sur Activate (ou "faire apparaître" depuis une icône plusieurs 

fenêtres).
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16 Aide  

16.1 Contenu de l'aide       F1  

Choisissez la commande Help>Help Contents pour charger le fichier d'aide de ToupSky. 

Le fichier d'aide est en format Portable Document Format (PDF).  

Le PDF est un format de fichier utilisé pour représenter des documents de manière 

indépendante des logiciels applicatifs, du matériel et des systèmes d'exploitation. 

Chaque fichier PDF encapsule une description complète d'un document à mise en page 

fixe, y compris le texte, les polices, les graphiques et autres informations nécessaires 

à son affichage. En 1991, le co-fondateur d'Adobe Systems, John Warnock, a esquissé 

un système appelé "Camelot" qui a évolué vers le PDF.  

Alors que la spécification PDF est disponible gratuitement depuis au moins 2001, le PDF 

était à l'origine un format propriétaire contrôlé par Adobe. Il a été officiellement publié 

en tant que norme ouverte le 1er juillet 2008, et publié par l'Organisation internationale 

de normalisation sous le numéro ISO 32000-1:2008. En 2008, Adobe a publié une 

licence de brevet publique pour l'ISO 32000-1 accordant des droits sans redevance 

pour tous les brevets détenus par Adobe qui sont nécessaires pour fabriquer, utiliser, 

vendre et distribuer des implémentations conformes au PDF. Si votre ordinateur n'a 

pas encore installé le lecteur PDF, veuillez essayer de le télécharger à partir de :  

http://www.adobe.com/downloads/  

16.2 À propos•••  

Afficher les informations relatives à ToupSky, y compris la version de ToupSky, 

Compatible, la date de Built et le site Web de son développeur, etc.  
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Cliquer sur le lien Web vous 
dirigera vers le site du 
fournisseur de l'application. Si 
vous avez des problèmes avec 
la caméra ou avec l'application, 
n'hésitez pas à contacter le 
service.  
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BRESSER GmbH 
Gutenbergstraße 2 

46414 Rhede 

Allemagne 

service@bresser.de 

www.bresser.de/service 

 

mailto:service@bresser.de
http://www.bresser.de/service
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